Bug 139930 - Objects anchored to frame don't move when frame moves (Linux-only)
Summary: Objects anchored to frame don't move when frame moves (Linux-only)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap Frame
  Show dependency treegraph
 
Reported: 2021-01-26 19:20 UTC by Steve Edmonds
Modified: 2022-02-02 16:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document exhibiting bug of frame moving without contents. (1.57 MB, application/vnd.oasis.opendocument.text)
2021-01-26 19:20 UTC, Steve Edmonds
Details
Document NOT exhibiting bug of frame moving without contents. (1.31 MB, application/vnd.oasis.opendocument.text)
2021-01-26 19:21 UTC, Steve Edmonds
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Edmonds 2021-01-26 19:20:17 UTC
Created attachment 169159 [details]
Document exhibiting bug of frame moving without contents.

I have objects in a frame, anchored to frame. The frame is anchored to paragraph.
If I select the frame and move it with the arrow keys, the frame and objects move.
If the paragraph to which the frame is anchored moves, the frame moves but the objects in the frame anchored to the frame stay where they are.

It is not a simple as the statement above.
Attached are 2 files, frameAnchorOK.odt and frameAnchorNOK.odt.
If I delete the red lines of text from frameAnchorNOK.odt the frame (only) with the images moves up but the contents stay.
If I delete the red lines from frameAnchorOK.odt the frame with the images moves up along with the contents.

I created frameAnchorOK.odt by copying and pasting from frameAnchorNOK.odt.
Comment 1 Steve Edmonds 2021-01-26 19:21:15 UTC
Created attachment 169160 [details]
Document NOT exhibiting bug of frame moving without contents.
Comment 2 Steve Edmonds 2021-01-28 00:36:48 UTC
Some more information from some tinkering.
As mentioned, when copying and pasting from the document exhibiting the bug into a new document (copied the bullet points and anchor for the frame so the frame and contents were selected and pasted into a table created in a new document) the bug no longer was evident.

Now if I do the reverse, and copy the content described above from the document no longer showing the bug back into a newly inserted page in the original document with the bug with inserted 3 column table then the bug is evident in this newly pasted content.

There would appear to be something about the original document that causes the bug that is not in the new clean document.
Comment 3 Dieter 2021-02-13 09:19:10 UTC
I couldn't reproduce the bug with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 396c2ad2daad6fe6a11703d0ae1593929834afe2
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Steps:
1. Open attachment 169159 [details]
2. Move the last paragragraph of the text down

Result: Frame and images inside move also down (as expected)

Steve, could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ or with a master build from http://dev-builds.libreoffice.org/daily/master/current.html? You can install master alongside the standard version. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 Steve Edmonds 2021-02-14 05:27:07 UTC
I am still getting this from 7.1.0.3.
I am not sure if you tested as I did.

Did you;
1. Open attachment 169159 [details]
2. Delete the red lines of text from frameAnchorNOK.odt (should the attachment above). These lines should be a part of a bulleted list.

I will look to install the daily build.
Comment 5 Dieter 2021-02-14 05:59:58 UTC
(In reply to Steve Edmonds from comment #4)
> I am not sure if you tested as I did.
> 2. Delete the red lines of text from frameAnchorNOK.odt (should the
> attachment above). These lines should be a part of a bulleted list.

Thanks for asking. No, I didn't, but I've tested now (with LO 7.1.0.3) and result is the same as in my previous test (looks O.K.). So perhaps only Linux?
Comment 6 Steve Edmonds 2021-02-14 08:41:12 UTC
I have access to windows and Mac, so will check on them.
Comment 7 Steve Edmonds 2021-02-14 19:42:02 UTC
I have tried this bug on 7.0.4.2 on windows 10 and Mac and neither exhibit the issue, so suspect it is Linux only.
Comment 8 Buovjaga 2022-02-02 15:21:33 UTC
Reproduced already with oldest of Linux 43all bibisect repo.

I was unable to find an existing report.

Arch Linux 64-bit
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: bff5d1a68a8b6f5776c5edb4ef0f919af1194d03
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded Jumbo
Built on 2 February 2022