Bug 139952 - Frame (page number field) removed when opening MO document in LO
Summary: Frame (page number field) removed when opening MO document in LO
Status: RESOLVED DUPLICATE of bug 124481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2021-01-28 01:05 UTC by Jorge
Modified: 2021-09-06 12:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Frame exists in MO (340.44 KB, image/png)
2021-01-28 01:05 UTC, Jorge
Details
Frame is lost in LO (244.17 KB, image/png)
2021-01-28 01:05 UTC, Jorge
Details
Docx to test (32.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-01-28 01:06 UTC, Jorge
Details
Doc with non-removed frame (56.50 KB, application/msword)
2021-01-28 01:07 UTC, Jorge
Details
Doc with non-removed frame (56.50 KB, application/msword)
2021-01-28 01:08 UTC, Jorge
Details
field settings in word (57.83 KB, application/pdf)
2021-08-08 07:00 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge 2021-01-28 01:05:06 UTC
Description:
When this document with this special frame created in MO is opened in LO the frame is lost, and as it is aligned to the right then the alignment is lost too. 
When the document is saved as doc with MO, the frame is not removed in LO.

Steps to Reproduce:
Open document in MO to verify frame exist
Open document in LO to verify frame is removed


Actual Results:
The frame is removed

Expected Results:
The frame and its settings remain the same 


Reproducible: Always


User Profile Reset: No



Additional Info:
Tested in 6.7.4.2 and in 7.0.4.2 LO versions
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx; 
Locale: en-US (en_CO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Jorge 2021-01-28 01:05:38 UTC
Created attachment 169199 [details]
Frame exists in MO
Comment 2 Jorge 2021-01-28 01:05:58 UTC
Created attachment 169200 [details]
Frame is lost in LO
Comment 3 Jorge 2021-01-28 01:06:36 UTC
Created attachment 169201 [details]
Docx to test
Comment 4 Jorge 2021-01-28 01:07:56 UTC
Created attachment 169202 [details]
Doc with non-removed frame
Comment 5 Jorge 2021-01-28 01:08:34 UTC
Created attachment 169203 [details]
Doc with non-removed frame
Comment 6 Jorge 2021-03-15 16:53:22 UTC
Updated steps to reproduce this issue 

Microsoft Word on version 16.45 = Issues
Microsoft Word on version 15.32 = No issues

- Create a Word document using Office 2016 on a MAC 16.45 or higher
- Type some text
- Click on Insert
- Click Header > Select the first option
- Click on Page Number > Page Number > Alignment - Right
Comment 7 Evgenija Chumachenko 2021-07-29 10:17:09 UTC
No repro in
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 67f2a99229101757af4f40118f4d3c83ba38648b
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-US (ru_RU); UI: en-US
Calc: threaded
Comment 8 raal 2021-08-08 06:46:26 UTC Comment hidden (obsolete)
Comment 9 raal 2021-08-08 06:59:52 UTC
Confirm with Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 36efb384a66b6dd645e0ae80fd7df68370a9dc8b
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

and Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

Frames (fields) are aligned left on the page, should be right.
Comment 10 raal 2021-08-08 07:00:37 UTC
Created attachment 174131 [details]
field settings in word
Comment 11 NISZ LibreOffice Team 2021-09-06 12:32:06 UTC

*** This bug has been marked as a duplicate of bug 124481 ***