Bug 140068 - Print option "Page background" effective only after restart; maybe the same for others, too
Summary: Print option "Page background" effective only after restart; maybe the same f...
Status: RESOLVED DUPLICATE of bug 138484
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2021-02-01 16:36 UTC by Gerhard Weydt
Modified: 2021-03-04 09:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
video (345.12 KB, video/mp4)
2021-02-01 20:36 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Weydt 2021-02-01 16:36:05 UTC
In writer, the option Print -> Page background becomes effective only after a restart of LibO. The help page (https://help.libreoffice.org/7.1/en-GB/text/shared/optionen/01040400.html?System=WIN&DbPAR=WRITER&HID=modules/swriter/ui/printoptionspage/PrintOptionsPage#bm_id3153750 in my Windows environment) says: "for all subsequent print jobs", which implies it has an immediate effect.
The new behaviour was introduced at some point between 5.2.7.2 and 6.4.7.2.
I have not tested the other options in Writer, nor have I checked that for the other modules.
The help page should provide that important information. I discovered the problem, because some one asked in the German user list, why this doesn't work any longer, which shows there is a need for that information.
Comment 1 BogdanB 2021-02-01 20:36:03 UTC
Created attachment 169365 [details]
video

In my tests, see the video, printing the background is not depending of that setting but from the setting from Print options.
Comment 2 BogdanB 2021-02-01 20:37:10 UTC
Also, the Print Window changed very much in the newest versions. 5.2 is a very very old version now.
Comment 3 Gerhard Weydt 2021-02-01 21:19:32 UTC
(In reply to BogdanB from comment #2 and comment #1)
> Also, the Print Window changed very much in the newest versions. 5.2 is a
> very very old version now.
Version 5.2 was only mentioned to provide a hint when the old behaviour was still in effect, I'm not using that myself, the person who posed the problem in the German user list said he had recently upgraded from version 5.x to 6.4.7.2 (which is a good conservative choice for the moment, I think).
Mind, I'm not saying we should go back to the old behaviour, I couldn't judge that without further information, my aim is to have the documentation updated by the information that a change of the option will need a restart to become effective. Perhaps you haven't seen that the component I chose is Documentation.
And yes, you are right, this option only sets the proposed value for the print dialog, and you can overwrite it there. But that is not the concern of the bug report, it's an addition to the documentation of the options dialog.
But, and that's the reason why I detected that flaw, the option also provides the setting for creating a PDF using File -> Export as..., where there is no chance in the dialog to set it individually, so it's important that people know how the option works.
The print dialog has changed very much, that's true, and I've followed the discussion, as for a long time it wasn't totaly visible in many instances. But the setting for printing the page background is there as it was before.
Comment 4 Olivier Hallot 2021-03-03 18:43:37 UTC
I'd like to know if the restart is working as designed or it is a bug.

If a restart is needed, a dialog should ask (as in changing the locale or adding an extension).
Comment 5 Olivier Hallot 2021-03-04 09:17:27 UTC

*** This bug has been marked as a duplicate of bug 138484 ***