Bug 140158 - EDITING Shape and textframe fall apart on inserting page break
Summary: EDITING Shape and textframe fall apart on inserting page break
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords:
: 139645 (view as bug list)
Depends on:
Blocks: Shape-Textbox
  Show dependency treegraph
 
Reported: 2021-02-04 16:20 UTC by NISZ LibreOffice Team
Modified: 2021-04-28 09:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Writer (9.45 KB, application/vnd.oasis.opendocument.text)
2021-02-04 16:20 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document in Writer (74.52 KB, image/png)
2021-02-04 16:21 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Writer (54.22 KB, image/png)
2021-02-04 16:21 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-02-04 16:20:57 UTC
Created attachment 169475 [details]
Example file from Writer

Attached file contains a simple shape with textframe, anchored as character.
Inserting a page break in front of this shape makes the shape jump to the newly inserted page, but the textbox stays on the first page.

Steps to reproduce:
    1. Open attached document
    2. Insert a page break with Ctrl+Enter

Actual results:
Shape is placed on the second page, textframe stays on the first.

Expected results:
Shape and textframe should not fall apart.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 318d384c596c1593667d6c936f55bf6ebd0c5db6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-GB
Calc: CL

Also in:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Shape and textframe already fall apart upon opening in:
Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: en-US (hu_HU); Calc: CL
Comment 1 NISZ LibreOffice Team 2021-02-04 16:21:22 UTC
Created attachment 169476 [details]
Screenshot of the original document in Writer
Comment 2 NISZ LibreOffice Team 2021-02-04 16:21:50 UTC
Created attachment 169477 [details]
Screenshot of the problem in Writer
Comment 3 Dieter 2021-02-19 07:39:40 UTC
I confirm it with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 28555fc345ac2ccdda0e4e0f3c812c646befe68b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Additional information:
If shape is anchored to character, everything works fine.
If shape is anchored to paragraph, only textbix moves to the second page and shape stays on first page
Comment 4 Commit Notification 2021-03-01 15:04:53 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/493a916a3113e877835c9bc7c93faef0d29f9a33

tdf#140158 tdf#138598 tdf#140598 sw: fix sync of AS_CHAR textboxes

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2021-03-02 09:42:33 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 94283af977246c70dbed4452d197b003d8bb14b9
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Attila Bakos, thanks for fixing this issue. Should it be closed as RESOLVED FIXED ?
Comment 6 Attila Bakos (NISZ) 2021-03-02 09:48:34 UTC
Thank you for notifying me, I just forgot to close this one.
Comment 7 Commit Notification 2021-03-02 11:15:38 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/6edeb6a8209a990e83f07c02753d606226f59be7

tdf#140158 tdf#138598 tdf#140598 sw: fix sync of AS_CHAR textboxes

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 NISZ LibreOffice Team 2021-04-28 09:38:21 UTC
*** Bug 139645 has been marked as a duplicate of this bug. ***