Bug 140187 - FILEOPEN DOCX Deleting after section break leaves dangling empty numbered paragraph
Summary: FILEOPEN DOCX Deleting after section break leaves dangling empty numbered par...
Status: VERIFIED DUPLICATE of bug 145068
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Track-Changes
  Show dependency treegraph
 
Reported: 2021-02-05 12:52 UTC by NISZ LibreOffice Team
Modified: 2022-05-27 08:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word (15.76 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-02-05 12:52 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer (129.31 KB, image/png)
2021-02-05 12:52 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-02-05 12:52:07 UTC
Created attachment 169499 [details]
Example file from Word

Attached document contains some numbered paragraphs closed with a section break, followed by sub-numbering finished with section break.
Deleting a numbering+sub-numbering part of this in Word with change tracking leaves a dangling non-deleted sub-numbered paragraph in Writer.

Steps to reproduce:
    1. Open attached document.

Actual results:
In Writer the 3 a. paragraph is not marked as deleted.

Expected results:
Should be marked as deleted.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 318d384c596c1593667d6c936f55bf6ebd0c5db6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-GB
Calc: CL

Also in:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

Differently bad in:
Version: 6.4.0.3 (x86)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: CL

And again differently bad in:
Version: 6.3.0.4 (x86)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-02-05 12:52:23 UTC
Created attachment 169500 [details]
Screenshot of the original document side by side in Word and Writer
Comment 2 Dieter 2021-03-03 16:45:46 UTC
I confirm it with

Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Additional observation:
In Word 2016, also Number 3 (before "Pellentesque") is deleted, in Writer Number 4 (before "Aenean") is deleted
Comment 3 Xisco Faulí 2022-05-03 12:11:16 UTC
Dear László Németh,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 4 László Németh 2022-05-23 10:00:49 UTC

*** This bug has been marked as a duplicate of bug 145068 ***
Comment 5 NISZ LibreOffice Team 2022-05-27 08:44:05 UTC
Verified in:
Version: 7.4.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: b6266207b55a7633dc82b02142215757512adfb7
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: threaded