Bug 140250 - Effects: Glow Radius and Soft Edge Radius should be independent of one another (rather than linked)
Summary: Effects: Glow Radius and Soft Edge Radius should be independent of one anothe...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.5
Keywords: bibisected, bisected
Depends on:
Blocks: GTK3 Sidebar-Properties
  Show dependency treegraph
 
Reported: 2021-02-07 21:33 UTC by Petr Valach
Modified: 2021-12-06 13:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
linked-effects (157.86 KB, image/png)
2021-02-07 21:34 UTC, Petr Valach
Details
before clicking on graphic item with glow (452.56 KB, image/png)
2021-07-28 04:28 UTC, Marcy Toal
Details
after clicking on item to select it, soft edge is added spontaneously (461.63 KB, image/png)
2021-07-28 04:29 UTC, Marcy Toal
Details
glow and soft edge are separate properties in 7.0.6.2, issue not present in this version (466.56 KB, image/png)
2021-08-03 02:32 UTC, Marcy Toal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Valach 2021-02-07 21:33:53 UTC
Description:
There is unable to use Glow and Soft edge effect independently. Using one of that cause using of two with same value.

Steps to Reproduce:
1. Open LibreOffice 7.1 Impress/Draw.
2. Create any object (rectangle).
3. Use Glow effect with some value.
4. Check Soft edge effect.
5. Do steps 3 and 4 in reverse order.

Actual Results:
Entering any value for one effect causes using same value in other. Effects are linked.

Expected Results:
Effects are independently.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.1.0.3 / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

NO PROBLEM IN LO 7.0.4
Comment 1 Petr Valach 2021-02-07 21:34:45 UTC
Created attachment 169559 [details]
linked-effects
Comment 2 Marcy Toal 2021-07-28 04:28:12 UTC
Created attachment 173896 [details]
before clicking on graphic item with glow
Comment 3 Marcy Toal 2021-07-28 04:29:09 UTC
Created attachment 173898 [details]
after clicking on item to select it, soft edge is added spontaneously
Comment 4 Marcy Toal 2021-07-28 04:32:39 UTC
reproducing this also in libreoffice 7.1.5_rc2-0ubuntu0.20.04-1~lo1

items in draw document created in earlier version had glow only, when clicked on soft edge of same amount as glow gets spontaneously added. glow and soft edge are linked in exact same manner as described by op.
Comment 5 Marcy Toal 2021-07-28 04:34:43 UTC
Version: 7.1.5.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.5~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded
Comment 6 BogdanB 2021-07-28 05:27:53 UTC
Confirm based on comment 4 and also by me with Version: 7.1.5.2 / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 7 Marcy Toal 2021-08-03 02:31:13 UTC
i downgraded to 7.0.6.2. issue is not present in this version. note that the glow and soft edge tools are separate items in this version of libreoffice. perhaps this is simply some kind of user interface error.

Version: 7.0.6.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.6-0ubuntu0.20.04.1_lo1
Calc: threaded
Comment 8 Marcy Toal 2021-08-03 02:32:32 UTC
Created attachment 174035 [details]
glow and soft edge are separate properties in 7.0.6.2, issue not present in this version
Comment 9 Petr Valach 2021-08-03 11:14:54 UTC
Retest on LO 7.1.5 and LO 7.2.0.2 OK. We can change sliders individually.

Version: 7.1.5.2 / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

Version: 7.2.0.2 / LibreOffice Community
Build ID: 614be4f5c67816389257027dc5e56c801a547089
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5 (cairo+xcb)
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 10 BogdanB 2021-08-03 12:36:14 UTC
Peter, I tested recently and was not working in the same version. Maybe is a gtk bug. It seems in kf5 it is working. Maybe is a weld problem.
Comment 11 Petr Valach 2021-08-03 12:41:28 UTC
Thank you BB, you're right. On GtK, there is still problem.
Comment 12 R. Green 2021-08-24 16:31:34 UTC
Yes, Ive noticed this issue too; Glow  Radius and Soft Edge Radius need to be independent.
Comment 13 Aron Budea 2021-11-13 23:58:57 UTC
The sidebar decks were combined in the following commit. Opening the deck was crashing for a bit, that got fixed with the second commit below. Adding CC: to Andreas Kainz.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=55281fe6d3cda23d37b0b0c368786c9fc4c5abe9
author		andreas kainz <kainz.a@gmail.com>	2020-10-02 13:24:17 +0200
committer	Andreas Kainz <kainz.a@gmail.com>	2020-10-19 13:06:01 +0200

"tdf#136073 combine glow and softedge sidebar section"

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ec9b799b48b7e93809d4ccbb6b8b3ea1642f7a13
author		andreas kainz <kainz.a@gmail.com>	2020-10-22 22:53:10 +0200
committer	Caolán McNamara <caolanm@redhat.com>	2020-10-23 17:07:07 +0200

Resolves: tdf#137615 fix EffectPropertyPanel
Comment 14 Caolán McNamara 2021-11-14 15:01:10 UTC
I know what the problem is so its an easy fix
Comment 15 Commit Notification 2021-11-15 10:21:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/093eb46aea59c2359d122bc8d2c2a7411e9b8a23

Resolves: tdf#140250 don't share adjustments between differerent spinbuttons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Caolán McNamara 2021-11-15 10:22:39 UTC
done in trunk, backport to 7-2 in gerrit
Comment 17 Commit Notification 2021-11-16 10:35:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/482aa3d22834b246cae7bc88e3bdaba968739884

Resolves: tdf#140250 don't share adjustments between differerent spinbuttons

It will be available in 7.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 BogdanB 2021-11-17 19:41:53 UTC
Verified. It's perfect now.

Version: 7.3.0.0.alpha1+ / LibreOffice Community
Build ID: fcad2503ede92b515076f9bb3162855dcc2c575d
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 19 Christian Lohmaier 2021-12-06 13:28:48 UTC
7.2.4 was a hotfix release, updating target in status-whiteboard