Bug 140257 - No way to set Outline level simply
Summary: No way to set Outline level simply
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2021-02-08 05:50 UTC by Quintao
Modified: 2021-02-11 18:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Writer 6.0 to demonstrate the problem (9.04 KB, application/vnd.oasis.opendocument.text)
2021-02-09 23:34 UTC, Gabor Kelemen
Details
The example file after setting Outline level 2 for 3 paragraphs (160.08 KB, image/png)
2021-02-09 23:36 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Quintao 2021-02-08 05:50:15 UTC
Description:
First of all, I do appreciate the 'standard' method of setting paragraph styles to headers, so that outline levels are attached to them.

But what if my header contains different font sizes and variable formatting? All the formatting gets lost with a para style added.

Also. what if I don't want to set up a para style? All I want to do is set font size 14 and Outline level 1, or 2.

OK, the manual method to do what I want to do is to open para settings and select Outline level. But doing this for every single header is annoying (and I tried to make a macro to do it with one click but it has no effect).

And there's another bug, select multiple headers and set Outline level and only the last selected header takes effect!

In my opinion, it would be useful to have an Outline level selector in the Navigator, that immediately sets the level of selected text (basically a handy shortcut to using the option in para settings).

Currently there is only a promote/demote function, that has no effect on text without any level (body text).

Hope this makes sense!

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Gabor Kelemen 2021-02-09 23:34:02 UTC
Created attachment 169636 [details]
Example file from Writer 6.0 to demonstrate the problem

"And there's another bug, select multiple headers and set Outline level and only the last selected header takes effect!"

This can be reproduced with the attached file:
- Open the Navigator, it displays under Headings the first paragraphs text
- Ctrl+DoubleClick on the numbered 3 paragraphs
- Format -> Paragraph
- On the Outline & Numbering tab select "Level 2" in the Outline level dropdown.

In the Navigator under Headings the third numbered paragraph text will appear instead of all three numbered paragraphs text.

This used to work in 6.3 and before until:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=88aa305d2fdb76b8cf1bcd589c698ae5167796e1

author	Caolán McNamara <caolanm@redhat.com>	2020-08-13 15:48:16 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2020-08-17 11:42:55 +0200

tdf#134439 honor FN_PARAM_PAM arguments
Comment 2 Gabor Kelemen 2021-02-09 23:36:09 UTC
Created attachment 169637 [details]
The example file after setting Outline level 2 for 3 paragraphs
Comment 3 Gabor Kelemen 2021-02-09 23:39:23 UTC
Adding CC to: Caolán McNamara
Comment 4 Caolán McNamara 2021-02-10 16:04:03 UTC
The problem is with

commit 34527cec54ca634b831cfa5ac1098c4046818ac3
Date:   Tue Jan 16 18:54:19 2018 +0100

    lokdialog: Convert the Format -> Paragraph... dialog to async exec.

so simply reverting the fix of 88aa305d2fdb76b8cf1bcd589c698ae5167796e1 won't get us to a working state. We need to copy the entire multiselection I guess.
Comment 5 Commit Notification 2021-02-10 17:40:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e08b446e46f56e15af58fdd4396afba1a316f9e5

tdf#140257 duplicate entire PaM ring when making copy

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2021-02-10 17:41:34 UTC
that seems to work in master, backport for 7-1 in gerrit
Comment 7 Commit Notification 2021-02-11 14:32:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/75d8743ba840307d409ad0df67347e3ae5e60425

tdf#140257 duplicate entire PaM ring when making copy

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-02-11 18:44:14 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0c262229337c43f125d8931cba40ab432f51a851

tdf#140257: sw: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.