Bug 140282 - Bug in Filling Form in a docx file - read only
Summary: Bug in Filling Form in a docx file - read only
Status: RESOLVED DUPLICATE of bug 130565
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://youtu.be/m5YpxMvOJTk
Whiteboard:
Keywords: bibisected, bisected, filter:docx
Depends on:
Blocks: DOCX-Content_Control DOCX-Doc-Protection
  Show dependency treegraph
 
Reported: 2021-02-09 00:16 UTC by paulo g.
Modified: 2021-12-20 13:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
docx file with fields that writer cannot edit, read-only error (130.99 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-02-09 00:19 UTC, paulo g.
Details
bug libreofffice read-only_noPW.docx: the protection password has been removed. (100.41 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-03-04 10:49 UTC, Justin L
Details
The example document in current master (327.48 KB, image/png)
2021-12-20 12:12 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paulo g. 2021-02-09 00:16:51 UTC
Description:
Writer cannot write text in some fields that are not protected. Even if i save the file in format odt the bug does not disappear.

Steps to Reproduce:
1. Open Docx file
2. Try to write in unprotected fields
3. Appears text box with a warning read-only

Actual Results:
It is impossible to edit that docx file

Expected Results:
You should be able to edit in unprotected fiedls like in M$Word.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
It happens in all versions of libreoffice
Comment 1 paulo g. 2021-02-09 00:19:38 UTC
Created attachment 169602 [details]
docx file with fields that writer cannot edit, read-only error

View error in action:
https://youtu.be/m5YpxMvOJTk
Comment 2 Xisco Faulí 2021-02-09 10:17:33 UTC
it seems the issue is happening since

author	Oliver Specht <oliver.specht@cib.de>	2016-04-25 13:25:39 +0200
committer	Oliver Specht <oliver.specht@cib.de>	2016-04-29 06:12:55 +0000
commit 523a3d18e98cd51aa8bf76cf76314a22ddc2b2cf (patch)
tree 287df68a893b7f657cec9bee1147906a5c2b880b
parent 16777b6bb0267c2b0602f1007a1e1fecac81329b (diff)
tdf#99434: import/export documentProtection-forms from .docx incl. test

Bisected with bibisect-linux-64-5.2

not sure it's a regression though

@Justin, I thought you might be interested in this issue
Comment 3 Justin L 2021-03-04 10:49:17 UTC
Created attachment 170207 [details]
bug libreofffice read-only_noPW.docx: the protection password has been removed.

Well, this certainly is NOT a regression. Before Oliver's patch, every part of the document was editable - not just certain form-text areas. 

My guess is that we don't support importing the w:sdt text field used in this form. SDT support is fairly new - starting in 2013-ish for dates only.

I didn't find a bug report that mentions this topic, although I imagine a duplicate exists somewhere.
Comment 4 paulo g. 2021-05-24 10:35:33 UTC
To "avoid" bug i have copy the file to a new blank document, and now it can be edit.
Comment 5 Gabor Kelemen (allotropia) 2021-12-20 12:12:09 UTC
Created attachment 177033 [details]
The example document in current master

Much better in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 82ceab070de76d447505a598d07d5a9a1c48d80d
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded

Now the content controls are imported as fields and can be edited.

One hiccup still: there is a checkbox form control after 9. Documentos that can not be checked in Writer, unlike in Word. That is bug 99571.
Comment 6 Gabor Kelemen (allotropia) 2021-12-20 13:16:38 UTC
This was essentially the same problem as bug 130565.

*** This bug has been marked as a duplicate of bug 130565 ***