Bug 140292 - Empty frame at undo
Summary: Empty frame at undo
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: bibisected, bisected, regression
: 136930 138354 (view as bug list)
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2021-02-09 12:38 UTC by Telesto
Modified: 2021-12-16 16:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (138.53 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-02-09 12:38 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-02-09 12:38:01 UTC
Description:
Empty frame at undo

Steps to Reproduce:
1. Open the attached file
2. Select the content on page 1
3. Backspace or CTRL+X
4. Undo

Actual Results:
Image of page 1 gone

Expected Results:
Not so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3ed9bba283a6a67864c0928186e277240be0d9ba
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

still OK in
Version: 6.4.0.0.beta1+ (x64)
Build ID: 20be5cd0bdc57d812bf34a2debfe48caa51de881
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2021-02-09 12:38:38 UTC
Created attachment 169617 [details]
Example file
Comment 2 mulla.tasanim 2021-02-09 21:17:25 UTC
Thank You for reporting the bug.

I can not reproduce the bug in,

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 3 Noora 2021-02-12 07:42:06 UTC
Thank you for reporting the bug. I can confirm that the bug with example file is present in, 

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: e0843b1fe6e39d3e5f14c8f13476008f17c8ed2e
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_FI); UI: en-US

Additional information: if you change the image on the first page or move the image to the second page, the bug won't be present.
Comment 4 raal 2021-02-20 22:56:13 UTC
This seems to have begun at the below commit.
Adding Cc: to Miklos Vajna ; Could you possibly take a look at this one?
Thanks
linux-64-7.2$ 02dabb58b790bf42b2504e6edd02cc5ef737fdcd is the first bad commit
commit 02dabb58b790bf42b2504e6edd02cc5ef737fdcd
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Jan 13 04:01:04 2021 +0100

    source sha:200cd2b99bee18962a970edc5d059286f6c3ea0e

commit 200cd2b99bee18962a970edc5d059286f6c3ea0e	[log]
author	Miklos Vajna <vmiklos@collabora.com>	Mon Jan 11 21:03:34 2021 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	Tue Jan 12 16:07:41 2021 +0100
tree 04b1b5b4c7fbe307f38c687b16ae815a6e4d1188
parent f2e04fe98e313cffa3f98d55eae641415142a431 [diff]

tdf#138995 DOCX import: fix handling of textbox zorders
Comment 5 Commit Notification 2021-03-09 07:37:31 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d2a45762f1b5f1c7093469e34d9f56defa88e9e4

tdf#140292 sw: fix z-order of textbox on undo

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2021-03-09 07:38:58 UTC
Michael Stahl fixed this in 3bc8f90e9693f710f12632f69b9348c1c833c906, I just added a testcase.
Comment 7 Xisco Faulí 2021-03-10 14:49:59 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 3dfe1df0f1084b06c7d4c95df387253b2e058cd6
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 8 Commit Notification 2021-03-11 12:26:05 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/18397b2ede1e6c3feb54bd2bf59da57fd8c4d13a

tdf#140292: (related: tdf#133487) sw: fix ordering of virtual SdrObjects for textboxes

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-03-11 12:27:22 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/291bc2799e4d384cb3ccbb429e82a8ea52d3ea2f

tdf#140292 sw: fix z-order of textbox on undo

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Stahl (allotropia) 2021-12-01 18:39:54 UTC
*** Bug 138354 has been marked as a duplicate of this bug. ***
Comment 11 Michael Stahl (allotropia) 2021-12-16 16:14:19 UTC
*** Bug 136930 has been marked as a duplicate of this bug. ***