Bug 140307 - EDITING: When selecting text there is no highlight. Text cursor also blinks wildly
Summary: EDITING: When selecting text there is no highlight. Text cursor also blinks w...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2021-02-09 22:00 UTC by matthew.sorrensen
Modified: 2021-03-10 05:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matthew.sorrensen 2021-02-09 22:00:44 UTC
Description:
Whenever I attempt to select text to cut/copy, there is no visual feedback as to what has been selected aside from the bar at the bottom of the screen "Select: x words, n characters". Pasting works as expected.

The text cursor also blinks at a fast rate

Steps to Reproduce:
1. Open any document
2. Attempt to select text
3.

Actual Results:
Cursor would blink normally and text would be selected with a highlight showing what had been selected

Expected Results:
Visual feedback (highlighted text) of what had been selected.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I'm running macOS Big Sur 11.2 (was also present with 11.1).
Comment 1 matthew.sorrensen 2021-02-12 05:05:18 UTC
I have just noticed that if a document is locked for editing and opens as read only (or manually set to read only) then the issue is no longer present.
Comment 2 Dieter 2021-03-03 20:12:23 UTC
I can't confirm it with

Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Perhaps only an issue in MAC.
Comment 3 mulla.tasanim 2021-03-09 21:25:50 UTC
Thank you for reporting the bug. 

I can not reproduce the bug in

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nb-NO (en_US); UI: en-US
Calc: CL

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 4 matthew.sorrensen 2021-03-10 00:08:03 UTC
Wiped Mac user profile (not just the LibreOffice profile) rectified issue.
Comment 5 Dieter 2021-03-10 05:12:15 UTC
(In reply to matthew.sorrensen from comment #4)
> Wiped Mac user profile (not just the LibreOffice profile) rectified issue.

=> RESOLVED NOTABUG