Bug 140316 - Language selection using 'For Paragraph' and 'For Selection' navigates to wrong dialog box
Summary: Language selection using 'For Paragraph' and 'For Selection' navigates to wro...
Status: RESOLVED DUPLICATE of bug 103036
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Languages
  Show dependency treegraph
 
Reported: 2021-02-10 10:16 UTC by dan
Modified: 2021-06-12 07:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dan 2021-02-10 10:16:22 UTC
Description:
When using the following menus...

Tools > Language > For Selection > More
Tools > Language > For Paragraph > More

The resulting dialog box is the wrong one. It doesn't give you the expected result, i.e. 'Options - Language Settings - Languages', instead it incorrectly directs to 'Character' dialog box.

Therefore you can't change the language for selected text or paragraph.

Thanks.

Steps to Reproduce:
1. Tools > Language > For Selection > More
2. Tools > Language > For Paragraph > More
3.

Actual Results:
Provides 'Character' dialog box.

Expected Results:
Should provide 'Options - Language Settings - Languages' dialog box.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.4.2 (x64)
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: CL
Comment 1 Dieter 2021-02-25 07:18:55 UTC
I confirm the observed behaviour, but I'm not sure, if this is a bug or the expected behaviour, because you can change langage of selectin in character dialog.

cc: Design-Team

Help page [1] is not a help here, because it says: "Choose More to open a dialogue box with more options." If the current behaviour is correct, help page should be changed to "Choose more to open the character dialog in order to choose the desired language" (or something like that).


[1] https://help.libreoffice.org/7.1/en-GB/text/shared/01/06010500.html?&DbPAR=WRITER&System=WIN
Comment 2 Heiko Tietze 2021-02-25 10:21:51 UTC
For Paragraph and For Selection are applied immediately where All leading to Tools > Options changes the default for new documents. We have some tickets about this.

For Selection is applied as direct formatting on the selection/characters and I would expect the Character dialog therefore. But For Paragraph is done as direct formatting on the paragraph and therefore the dialog title is indeed misleading. 

But the function works as expected as you can see in the newly introduced Styles Inspector.
Comment 3 Mike Kaganski 2021-02-25 10:36:04 UTC

*** This bug has been marked as a duplicate of bug 103036 ***