Bug 140341 - Pictures disappear upon updating the table of contents
Summary: Pictures disappear upon updating the table of contents
Status: RESOLVED DUPLICATE of bug 138785
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2021-02-11 15:06 UTC by Wapa
Modified: 2021-08-18 12:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with Table of Contents and Pictures (5.03 MB, application/vnd.oasis.opendocument.text)
2021-02-11 15:07 UTC, Wapa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wapa 2021-02-11 15:06:53 UTC
Description:
Closing and reopening the document makes them reappear.

Steps to Reproduce:
1. Open the attached document.
2. Make some edits. (probably not even needed)
3. Update the table of content.

Actual Results:
Why is this field mandatory even though it doesn't have a red asterisk?

Pictures are replaced with placeholders.

Expected Results:
Pictures still there.


Reproducible: Always


User Profile Reset: No



Additional Info:
Again, why is this a mandatory field?
Comment 1 Wapa 2021-02-11 15:07:59 UTC
Created attachment 169674 [details]
File with Table of Contents and Pictures
Comment 2 BogdanB 2021-02-11 19:36:16 UTC
Confirm with
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 066799b4a162aa0a4bc6aa28339f1f943a13971e
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 3 BogdanB 2021-02-11 19:39:07 UTC
Also in
Version: 6.0.7.3
Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk2; 
Locale: ro-RO (ro_RO.UTF-8); Calc: group

Also in
Version 3.6.7.2 (Build ID: e183d5b)

I could supose it is inherited from OOo.
Comment 4 Wapa 2021-08-13 16:31:02 UTC
I wasn't able to reproduce this with 7.2.0.3
Comment 5 BogdanB 2021-08-14 18:59:49 UTC
Working well in
Version: 7.1.5.2 / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Also in
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: c97bdca2d7abf30a99c45192b8f49c5bf76ca035
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 6 Timur 2021-08-18 12:48:11 UTC
IN 7.1
commit ee1cd9b7eb8cb756bea647931383a50b4e1ca6d5
Date:   Fri Apr 23 20:00:09 2021 +0200
    source sha:c79b92edfb5e650fff76688998cf4f0bbd08d2a4
    pre sha:810f7e4e0b61ee7cb3a7d6a1b503782d7248a4b1

author	Michael Stahl <michael.stahl@allotropia.de>	2021-04-20 12:45:36 +0200
committer	Thorsten Behrens <thorsten.behrens@allotropia.de>	2021-04-23 17:03:42 +0200
commit c79b92edfb5e650fff76688998cf4f0bbd08d2a4 (patch)
tree 42f6c26de5181c0243ce81333aebf80ac83c886d
parent 810f7e4e0b61ee7cb3a7d6a1b503782d7248a4b1 (diff)
tdf#138785 sw: fix mis-positioned as-char flys when deleting empty page

Don't know how this one is Inherited and bug 138785 regression, but important that fix is known and done.

*** This bug has been marked as a duplicate of bug 138785 ***