Bug 140397 - Navigator in master documents: button for Toggle Master view missing (all backends except GTK3)
Summary: Navigator in master documents: button for Toggle Master view missing (all bac...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Jim Raykowski
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords: bibisected, bisected, regression
: 140647 140887 140945 140973 (view as bug list)
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2021-02-13 18:56 UTC by Olivier Hallot
Modified: 2021-03-12 10:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2021-02-13 18:56:00 UTC
The Master document view in the Navigator for master document does not work.

Step to reproduce.

1) Create a new master document
2) open navigator (F5)
3) Switch to Normal view.
4) Switch back to Master view

Expected result: Navigator in Master view

Actua results: stays in Normal view, button is ineffective

There is no way to get the Master view in the user interface. Even opening another master document, the navigator stays in Normal view


Further info:

Profile was reset to factory: same behaviour.

Version: 7.1.0.3 / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: pt-BR
Calc: threaded
Comment 1 Buovjaga 2021-02-14 16:25:51 UTC
The button is there with gtk3, but not with kf5, gen or Windows.

Bibisected with linux-64-7.1 to

https://git.libreoffice.org/core/commit/b80c2745c50d064ad9e673cf8a5b73aaf0aa1778
tdf#137777 Writer: fix keyboard navigation of Navigator

Adding Cc: to Jim Raykowski
Comment 2 Jim Raykowski 2021-02-24 02:07:06 UTC
Apologies for the delay. Looks like I missed the visibility property setting for the button. Here is a patch to correct this:
https://gerrit.libreoffice.org/c/core/+/111439
Comment 3 Commit Notification 2021-02-24 03:49:27 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2b8ce3d62b71ca91df464e26ccc6c6c79d6c886f

tdf#140397 make contenttoggle button visible again in all backends

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Buovjaga 2021-02-24 07:21:55 UTC
Thanks, it's working now

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: e5f436bc53e0d07654901ef7cc8ff56d04f0686e
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 24 February 2021
Comment 5 Olivier Hallot 2021-02-24 11:21:25 UTC
I cherry-picked for 7.1 branch. Please approve and merge.
Comment 6 Commit Notification 2021-02-24 11:30:43 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/608151c7de0f0661783daceecd9250bdcf497b59

tdf#140397 make contenttoggle button visible again in all backends

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2021-02-24 19:47:39 UTC
*** Bug 140647 has been marked as a duplicate of this bug. ***
Comment 8 Julien Nabet 2021-03-08 17:10:20 UTC
*** Bug 140887 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2021-03-11 07:35:36 UTC
*** Bug 140945 has been marked as a duplicate of this bug. ***
Comment 10 Buovjaga 2021-03-12 10:37:46 UTC
*** Bug 140973 has been marked as a duplicate of this bug. ***