Bug 140416 - dragging destination hover-guides messed up, especially for RTL sheet deck
Summary: dragging destination hover-guides messed up, especially for RTL sheet deck
Status: RESOLVED DUPLICATE of bug 140417
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2021-02-14 21:37 UTC by Eyal Rozenberg
Modified: 2022-02-18 15:20 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2021-02-14 21:37:37 UTC
Description:
When you click-and-hold on a tab in the sheet deck in Calc, and move the sheet left or right, LO paints small triangles/arrow-heads on both sides of the boundary between adjacent sheet tabs, where your sheet would be placed if you release the mouse.

However:

1. If your sheet tab deck is in RTL mode (which happens when the current sheet is in RTL direction), the triangles are drawn on the two opposite sides of adjacent sheet tabs. So, in both cases it's on the right side of the earlier tab and the left side of the latter tab, instead of being on the 'end' side and 'start' side respectively. A screenshot will follow.

2. Bits of the triangles are left behind when you move around with your selected tab (without having released the mouse). This is an unrelated bug which you will see manifested in the screenshot, but - please ignore it in the context of this bug.

Steps to Reproduce:
1. Open Calc
2. Add a few more sheets, for a total of, say, 4.
3. Select the fourth sheet in the deck.
4. Ensure the sheet direction is RTL (e.g. using the Sheet menu).
5. Hold down your mouse on the 4th sheet's tab in the tab deck
6. Drag the sheet-tab slowly over the other sheet-tabs in the deck

Actual Results:
Triangles drawn on opposite ends of consecutive sheet-tabs.

Expected Results:
Triangles drawn on adjoining ends of consecutive sheet-tabs.


Reproducible: Always


User Profile Reset: No



Additional Info:
Tested with:

Version: 7.1.0.3 / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 4; OS: Linux 5.9; UI render: default; VCL: gtk3
Locale: he-IL (en_IL); UI: en-US
Calc: threaded

But I believe this has been happening for a while.
Comment 1 [REDACTED] 2021-02-14 23:05:22 UTC

*** This bug has been marked as a duplicate of bug 140417 ***