Download it now!
Bug 140448 - Make "Navigate By" Page up & down toolbar buttons accessible as keyboard shortcuts
Summary: Make "Navigate By" Page up & down toolbar buttons accessible as keyboard shor...
Status: RESOLVED DUPLICATE of bug 101211
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigate-By
  Show dependency treegraph
 
Reported: 2021-02-16 14:18 UTC by Robert Phair
Modified: 2021-06-13 17:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of the buttons we want as keyboard shortcuts (14.11 KB, image/png)
2021-02-16 14:24 UTC, Robert Phair
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Phair 2021-02-16 14:18:04 UTC
Description:
The feature I observe as missing (on both LibreOffice major versions 6 and 7 under Linux / Ubuntu 18.04 and 20.04) is agreed to be missing by the predominantly Windows community (via attempts to work around the missing feature), most recently here (OP paraphrased into this bug report):

https://ask.libreoffice.org/en/question/293269/navigate-top-next-page-shortcut

It's hard to classify this as a "feature request" (i.e. something new) since it seems more like a "minor bug" of having left these button functions out of the list of Keyboard Shortcuts:

Steps to Reproduce:
1. Observe behaviour of up & down arrow buttons (circled in red) Ion this ("Find"?) toolbar, which navigate the user up & down by page view (keeping whole pages together in the window when possible, with the page top aligned with the top of the window, and also the bottom with the bottom View > Zoom = Entire Page):

(image link) https://ask.libreoffice.org/upfiles/16132256986967906.png

2. Attempt to duplicate the behaviour of these toolbar buttons (only possible to press with the mouse) by a Keyboard Shortcut, as is possible with other navigation features.

3. Observe that the two closets equivalents in the Keyboard Shortcut grouping for "Navigate" are "To Begin of Previous Page" and "To Begin of Next Page"... which move the page focus up & down *by insert point* but **not** by page view, focusing the insert point in the middle of the window and straddling two pages.

Actual Results:
N/A

Expected Results:
N/A


Reproducible: Always


User Profile Reset: No



Additional Info:
See the forum thread linked above for workflow rationale why this mouse-dependent should also be accessible as a Keyboard Shortcut like almost everything else in LibreOffice.  In short: it's generally desirable for users to be able to map the PgUp and PgDn keys to the same behaviour of the toolbar buttons above... so they can view the document page by whole page while editing instead of just moving around the insert point.

For an illustrative example please imagine proofreading the titles of a 3000 page document (like the Chicago Manual of Style, with the page headings all at the top) with the top of page jumping around the window each time, never being able to see the header and footer together on the same page view.
Comment 1 Robert Phair 2021-02-16 14:24:20 UTC
Created attachment 169784 [details]
screenshot of the buttons we want as keyboard shortcuts
Comment 2 Dieter 2021-03-03 08:34:15 UTC
I think, this is an enhancement request.

Jim, what do you think about it?
cc: Jim Raykowski
Comment 3 Robert Phair 2021-03-03 14:59:45 UTC
I'd agree that this is an "Enhancement Request" if and only if someone can explain why, historically or technically, those up- and down-arrow button functions were left off the list of Keyboard Shortcut-able functions in the first place.
Comment 4 Jim Raykowski 2021-03-04 00:37:19 UTC
Is this solved by the enhancement patch done for bug 101211?
Comment 5 Dieter 2021-03-04 08:12:42 UTC
(In reply to Jim Raykowski from comment #4)
> Is this solved by the enhancement patch done for bug 101211?

Sorry, If made a mistake, when writing my comment 2. Yes, keyboard shortcuts are available (commands: Previous element / Next element)

Tested with

Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

Robert, please explain, why this doesn't work for you.
=> NEEDINFO
Comment 6 Robert Phair 2021-03-04 08:43:25 UTC
They DO work, even in our current version 7.0.4.2 ... we just had no way of knowing they were available until your last message.  Thank you: those shortcuts map to those toolbar buttons perfectly and our own problem is solved.

We couldn't find this because (I see in hindsight because of the selectable function) hovering over it with the "Page" element selected gives tooltips of Previous Page and Next Page without using the more general word "Element."  Therefore maybe this is a documentation issue, because the Keyboard Shortcut UI is only self-documenting if you anticipate how the term "Element" is used.
Comment 7 Dieter 2021-03-04 09:12:21 UTC
So I close it as RESOLVED WORKSFORME. If you think, tooltip should be improved (for example "Previous element (page)", "Previous element (footnote)" and so on), please open a new bug report. Thank you.
Comment 8 V Stuart Foote 2021-06-13 17:03:28 UTC

*** This bug has been marked as a duplicate of bug 101211 ***