Bug 140459 - numpad not working in RTL language
Summary: numpad not working in RTL language
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2021-02-17 04:32 UTC by Fahad Al-Saidi
Modified: 2022-02-18 15:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fahad Al-Saidi 2021-02-17 04:32:02 UTC
Description:
I face a wired problem. In Arabic layout numpad not working in Libreoffice only. the other apps work fine. It seems that I am not the only one, see:
https://ask.libreoffice.org/en/question/167488/numpad-not-working-in-persian-language/

Steps to Reproduce:
1. add arabic keyboard layout
2. open writer 
3. change keyboard to arabic
4- try to use numpad

Actual Results:
numpad not working

Expected Results:
numpad working


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.6.2
Build ID: 1:6.4.6-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ar-OM (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Fahad Al-Saidi 2021-09-28 07:43:58 UTC
To be clear, this happens when using a keyboard with Arabic-indic numerals.
Comment 2 Xisco Faulí 2021-09-28 08:39:23 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Fahad Al-Saidi 2021-09-28 08:59:58 UTC
I test it with libreoffice7.2 & the problem is gone.
Comment 4 Xisco Faulí 2021-09-28 09:01:04 UTC
Nice. Closing as RESOLVED WORKSFORME