Bug 140539 - Crash when I open the help window
Summary: Crash when I open the help window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2021-02-19 15:46 UTC by twilatson
Modified: 2021-03-24 13:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (51.96 KB, text/plain)
2021-02-23 14:27 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description twilatson 2021-02-19 15:46:03 UTC
Description:
It crashes when I open the help window (F1) but nothing more

Steps to Reproduce:
1. Keep pressing F1 until it crashes.

Actual Results:
I close all windows, reopen free office and retrieve the saved document automatically (with automatic backup)

Expected Results:
I don't know what to say. Not crash, I don't see what I can answer


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: CL
Comment 1 Lucia Rodriguez 2021-02-20 15:08:58 UTC
~Observations~
I was not able to reproduce the crash with the information provided in the description. 

I tried to reproduce this in two ways:

First Way
1. Opening a saved document in Writer.
2. Pressing F1 multiple times.

Second Way
1. Opening Writer 
2. Pressing F1 multiple times.

~ENVIRONMENT FOR TEST WITH LIBREOFFICE IN FRENCH~
Operating system: Windows 10 Home Edition 64-bit
Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: threaded

I also tried this in the english version of LibreOffice and was not able to reproduce the crash.

~ENVIRONMENT FOR TEST WITH LIBREOFFICE IN ENGLISH~
Operating system: Windows 10 Home Edition 64-bit
Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Additional Information:
I downloaded the french help package (LibreOffice_7.1.0_Win_x64_helppack_fr.msi) for the first test, andthe english help package (Additional Information:
I downloaded the french help package (LibreOffice_7.1.0_Win_x64_helppack_fr.msi) for the second one.
Comment 2 twilatson 2021-02-20 17:11:04 UTC
In fact I didn't press F1 several times. I kept pressing F1 until the crash (for several seconds).
Comment 3 Julien Nabet 2021-02-23 14:27:37 UTC
Created attachment 170001 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
Comment 4 Xisco Faulí 2021-02-25 08:32:55 UTC
I do reproduce it in

Version: 7.1.0.3 (x86) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: es-ES
Calc: threaded

but not in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: af64bc49d872d8a040d66387303def98eae5cd51
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Xisco Faulí 2021-03-22 14:42:50 UTC
this looks similar to bug 141166

*** This bug has been marked as a duplicate of bug 141166 ***
Comment 6 Caolán McNamara 2021-03-22 15:53:09 UTC
juliens bt looks like on pressing F1 the help window is launched, there is a yield, another F1 is seen and help window is launched while the help window is being launched, etc
Comment 7 Caolán McNamara 2021-03-22 16:19:23 UTC
https://gerrit.libreoffice.org/c/core/+/112804 likely solves julien's bt, but its not to certain that it has an effect on other platforms like the original windows report
Comment 8 Caolán McNamara 2021-03-22 16:20:02 UTC
but it is plausible it has an effect there too
Comment 9 Commit Notification 2021-03-22 20:01:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/60dd4825ba8fbab211fbb31961ea11873406a280

tdf#140539 don't allow help to be relaunched during launch

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2021-03-22 20:06:53 UTC
done in master, backport to 7-1 in gerrit
Comment 11 Commit Notification 2021-03-22 20:16:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/c83fc23a69949a8408c9e4ad8dc19ee9fa9d82a1

tdf#140539 don't allow help to be relaunched during launch

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-03-24 13:49:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-2":

https://git.libreoffice.org/core/commit/497610cfa5aea65d7f95966a54498b279f598631

tdf#140539 don't allow help to be relaunched during launch

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.