Bug 140574 - [EMF] Image has wrong background colour
Summary: [EMF] Image has wrong background colour
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-21 01:29 UTC by TorrAB
Modified: 2021-05-21 19:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
file with 2 figures (139.93 KB, application/vnd.oasis.opendocument.text)
2021-02-21 01:31 UTC, TorrAB
Details
file with 3 figures; one empty (153.57 KB, application/vnd.oasis.opendocument.text)
2021-02-24 02:11 UTC, TorrAB
Details
image to insert in GreenBlka.odt (118.74 KB, image/x-emf)
2021-02-24 02:14 UTC, TorrAB
Details
file with 3 figures; one black (148.80 KB, application/vnd.oasis.opendocument.text)
2021-02-24 02:16 UTC, TorrAB
Details
Screenshot which illustrate behaviour on LO 7.2 master (78.20 KB, image/png)
2021-03-24 11:52 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2021-02-21 01:29:36 UTC
Description:
In GreenBlk.odt, the image in Fig·44 has style Graphics, with a green background. The image in Fig·50 also has style Graphics, but its background is black. Why? I did not change it ‘by hand’. I made Fig·50 by copying Fig·44 and inserting another image (of the same type) in it.


Steps to Reproduce:
1.copy frame with image

2.delete image, insert a new one
3.

Actual Results:
new image has unexpected black background.

Expected Results:
new image should have green background specified in Graphics.


Reproducible: Always


User Profile Reset: No



Additional Info:
none
Comment 1 TorrAB 2021-02-21 01:31:41 UTC
Created attachment 169937 [details]
file with 2 figures
Comment 2 melody cercenia 2021-02-21 04:51:25 UTC
Melody Cercenia (21/02/21)

Unable to reproduce the issue.  Using the same version in windows.

Further check and investigate.  
- was able to update the color background of image in figure 44 but not the image in figure 50.
- looks like the image in figure 44 are transparent compared to image in figure 50. 
It might changed after pasting to the graph. Would be good to provide the original file of the image. The file before it became color black.

Thank you
Comment 3 TorrAB 2021-02-24 02:08:05 UTC
(In reply to melody cercenia from comment #2)
> Melody Cercenia (21/02/21)

> - looks like the image in figure 44 are transparent compared to image in
> figure 50.
**Both images have NoTransparency (^click>Properties>Transparency)

Fig·50, black in GreenBlk.odt, is normal in GreenBlka.odt. Now, go to Fig·52 in GreenBlka.odt, and insert YZ3!SinRP100.emf: black! —GreenBlkb.odt
Comment 4 TorrAB 2021-02-24 02:11:47 UTC
Created attachment 170011 [details]
file with 3 figures; one empty
Comment 5 TorrAB 2021-02-24 02:14:53 UTC
Created attachment 170012 [details]
image to insert in GreenBlka.odt
Comment 6 TorrAB 2021-02-24 02:16:50 UTC
Created attachment 170013 [details]
file with 3 figures; one black
Comment 7 mulla.tasanim 2021-03-18 16:30:29 UTC
Thank you for reporting the bug. 

I can not reproduce the bug in

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nb-NO (en_US); UI: en-US
Calc: CL

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 8 Bartosz 2021-03-24 11:52:58 UTC
Created attachment 170693 [details]
Screenshot which illustrate behaviour on LO 7.2 master

I was able to reproduce that issue by, drag attachment#170012 [details] into LibreOffice.

See attached screenshot.

Software: 
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: a8c23e5e5bd36899320c93d22040a093fe7a6c04
CPU threads: 12; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: CL
Comment 9 Bartosz 2021-05-14 14:24:29 UTC
The image under LO 7.2 looks identically as in MS Paint.
Please confirm and if possible check which commit fixed that issue.
Comment 10 BogdanB 2021-05-21 09:02:57 UTC
It's ok in Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 05366b8e6683363688de8708a3d88cf144c7a2bf
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded