Bug 140597 - FILEOPEN: DOCX: missing borders in some cells
Summary: FILEOPEN: DOCX: missing borders in some cells
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.2 target:7.0.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2021-02-22 13:04 UTC by Xisco Faulí
Modified: 2021-03-11 20:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.2 master (107.94 KB, image/png)
2021-02-22 13:04 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-02-22 13:04:59 UTC
Created attachment 169961 [details]
Comparison MSO 2010 and LibreOffice 7.2 master

Steps to reproduce:
1. Open attachment 47260 [details] from bug 37704

-> Some cells in table 1 have no border. See comparison image

Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 26d23c96d449c201e50df04023d9cbfd59d3d133
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2021-02-22 13:06:13 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f319d6b543c2367546bc80d138e56ed03731e265

author	László Németh <nemeth@numbertext.org>	2020-12-04 20:47:04 +0100
committer	László Németh <nemeth@numbertext.org>	2020-12-07 12:57:46 +0100
commit	f319d6b543c2367546bc80d138e56ed03731e265 (patch)
tree	d69c2b460d5c5760b1503c9d622ba04ef2dd1c55
parent	fbc909364c9c3964c1354169527e68446905c39b (diff)
tdf#138612 DOCX import: fix lost part of split table cell

Bisected with: bibisect-linux64-7.2

Adding Cc: to László Németh
Comment 2 Commit Notification 2021-03-10 09:10:50 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/53884e8fe92597e909e4fa5599192783c3d31a56

tdf#140597 DOCX import: fix missing tblPrEx border

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 László Németh 2021-03-10 09:11:06 UTC
tdf#140597 DOCX import: fix missing tblPrEx border

of first table cells, caused by the workaround for tdf#138612.

Now property set of a new cell is a copy of the table exception
property set of the table row, as needed for the import of the
table style inheritance.

Regression from commit f319d6b543c2367546bc80d138e56ed03731e265
(tdf#138612 DOCX import: fix lost part of split table cell).
Comment 4 László Németh 2021-03-10 09:11:33 UTC
@Xisco: thanks for reporting the problem!
Comment 5 Xisco Faulí 2021-03-10 11:25:05 UTC
Verified using as local build with the patch included.

@László Németh, thanks for fixing this issue!!
Comment 6 Commit Notification 2021-03-10 14:28:59 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/ff94f7779232088728bf724ec47608f35f5310b7

tdf#140597 DOCX import: fix missing tblPrEx border

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 László Németh 2021-03-10 20:52:01 UTC
(In reply to Xisco Faulí from comment #5)
> Verified using as local build with the patch included.
> 
> @László Németh, thanks for fixing this issue!!

@Xisco: thanks for the feedback, also for back porting!
Comment 8 Commit Notification 2021-03-11 20:50:03 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/1247f2f3d8f343e0e809a1aec0ce0e20005caafd

tdf#140597 DOCX import: fix missing tblPrEx border

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.