Bug 140696 - vba initialisation of variables
Summary: vba initialisation of variables
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2021-02-27 12:28 UTC by Harald Langheinrich
Modified: 2022-09-16 18:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
impossible error message (161.56 KB, image/png)
2021-02-27 12:35 UTC, Harald Langheinrich
Details
this file is under development it took time to depersonalize it (221.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-03-19 05:05 UTC, Harald Langheinrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Langheinrich 2021-02-27 12:28:55 UTC
Description:
Option VBASupport 1
Option Compatible
Option explicit

I have my VBA in several Makromodules (sheets) . Some Variables are defined as global so that i can reach them from another sheet. If I want to test a new part of program. Only the variables in this sheet are initialized newly...
... and I get unexpected errors with totally idiotic error messages .
if mark this step with a stop and run again then it works without error message 

i have have to restart the new part several times till it works without error messages ( I do not change anything in the program )

I think this has to do with initialisation of variables from other modules

Actual Results:
Basic Laufzeitfehler "13"

Expected Results:
no error


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: BasicIDE
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Harald Langheinrich 2021-02-27 12:35:19 UTC
Created attachment 170111 [details]
impossible error message

first run error was thrown in the line above the marked one 

then i did a rerun and it ran over that line without an error and stopped in the next line.

... and as you see in the observer field this message can't be correct
Comment 2 Xisco Faulí 2021-03-18 17:28:11 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 3 Harald Langheinrich 2021-03-19 05:05:01 UTC
Created attachment 170562 [details]
this file is under development  it took time to depersonalize it

when trying to repair errors and i run the this part for the first time it stucks with eroor message and if i run it for a second time it starts to work
Comment 4 Xisco Faulí 2022-05-03 12:07:22 UTC
Dear Harald Langheinrich,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 5 Aron Budea 2022-07-11 00:27:37 UTC
This was accidentally set to assigned, let's wait until someone else can confirm the bug.
Comment 6 Rafael Lima 2022-09-16 18:56:59 UTC
(In reply to Harald Langheinrich from comment #3)
> Created attachment 170562 [details]
> this file is under development  it took time to depersonalize it

Hi... Have you been able to solve this issue?

I am trying to reproduce this bug, but I can't find which macro triggers the problem. Can you please provide a set of steps that cause the error so that I can reproduce it with the provided sample file?