Bug 140761 - LO 7.1.0.3 issues with Writer on macOS Big Sur with External display - Display has rendering issues it seems
Summary: LO 7.1.0.3 issues with Writer on macOS Big Sur with External display - Displa...
Status: VERIFIED DUPLICATE of bug 138122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-02 14:00 UTC by alexandrefarley
Modified: 2021-03-03 22:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexandrefarley 2021-03-02 14:00:48 UTC
Description:
Hi!

After posting this on the https://ask.libreoffice.org/en/question/296033/lo-71-issues-on-mac-os-x-big-sur-with-external-display/ , I was asked to submit a bug report here.

I've decided to upgrade to Mac OS X Big Sur 11.0.1 today.... Crap ! It's not the latest version of Biog Sur I know. But another user on the Forum website confirmed the issue is still going on with Big Sur 11.2.1

I used to have LO 6.4.2002 on Catalina and there was no issue.

I've been working with an external display 27" 4k Philipps brilliance 272P connected to my MBP 13" inch through USB-C cable.

The resolution 3840 X 2160 at 30Hz

After I upgraded to Big Sur, I saw that LO 6.4.2002 wouldn't open. So I downloaded and installed LO 7.1.0.3

It opens well but the documents I used to work on with my external display, now have display issues. See screencast here: 

https://drive.google.com/file/d/1hV3-7qlQyyUCv17-jiEizt3un292Zwqk/view?usp=sharing

the screencast shows the difference between working on the document on my MBP display and working with it on my External 4K display.

I tried creating a new writer document from scratch and it does the same thing. I tried with a Calc and Presentation and the issue does not happen with those. It only happens with Writer documents.

What's up with that?

Is there a way to fix it?

Alex.

Steps to Reproduce:
1.With the setup previously explained (MacBook Pro connected to an external display), open a Writer document and drag it on the external display
2.Type text in the document
3. Zoom to page width
4. scroll through pages

Actual Results:
The document content is not displaying properly, it lags, it doesn't render as it should.

Expected Results:
Document content should scroll with no problem and display properly as it does on my MacBook Pro internal display


Reproducible: Always


User Profile Reset: No



Additional Info:
no other info to provide.
Comment 1 Julien Nabet 2021-03-02 16:54:14 UTC
Thorsten: thought you might be interested in this one since it concerns display on MacOs.
(don't hesitate to tell me if you prefer not being put in cc of bugtrackers)
Comment 2 Thorsten Wagner 2021-03-03 00:39:06 UTC
Issue should be fixed, but patch is on master branch only and has not been merged to release branch unitl now (see tdf#138122).
Comment 3 steve 2021-03-03 09:02:07 UTC
@Alexandre: It appears that the issue you are seeing should be addressed.

Could you try the latest macOS nightly build from here: https://dev-builds.libreoffice.org/daily/master/current.html and report back if you can confirm the issue is indeed solved?

*** This bug has been marked as a duplicate of bug 138122 ***
Comment 4 alexandrefarley 2021-03-03 16:08:43 UTC
Hi!

I just tried the nightly build here: https://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@tb81-TDF/2021-03-03_05.00.59/LibreOfficeDev_7.2.0.0.alpha0_MacOS_x86-64.dmg

And it works perfectly.

Alex.