Bug 140783 - Translated strings in Weblate not making it to the release version
Summary: Translated strings in Weblate not making it to the release version
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Hebrew RTL-UI
  Show dependency treegraph
 
Reported: 2021-03-03 19:08 UTC by Eyal Rozenberg
Modified: 2021-04-30 15:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2021-03-03 19:08:55 UTC
If you install the Hebrew language pack for LO 7.1.0.3 and start Writer, you'll notice that two of the menus, "Form" and "Table", have their English names (as opposed to, say, "טופס" and "טבלה").

However, it seems that at least word "Form" _is_ translated on Weblate:

https://translations.documentfoundation.org/translate/libo_ui-master/officecfgregistrydataorgopenofficeofficeui/he/?checksum=a209d936575c30b1

and AFAICT that's not a recent translation. So, why has it not been carried forward into the release (e.g. via gerrit)?
Comment 1 Ming Hua 2021-03-04 07:15:53 UTC
(In reply to Eyal Rozenberg from comment #0)
> If you install the Hebrew language pack for LO 7.1.0.3 and start Writer,
> you'll notice that two of the menus, "Form" and "Table", have their English
> names (as opposed to, say, "טופס" and "טבלה").
> 
> However, it seems that at least word "Form" _is_ translated on Weblate:
Actually, no.

> https://translations.documentfoundation.org/translate/libo_ui-master/
> officecfgregistrydataorgopenofficeofficeui/he/?checksum=a209d936575c30b1
This is not the string for Writer's main menu (likely somewhere in Base because its context starts with "BaseWindowState.xcu", but I didn't investigate), the correct string for Writer's "Form" menu is:

https://translations.documentfoundation.org/translate/libo_ui-master/officecfgregistrydataorgopenofficeofficeui/he/?checksum=cbd1c0af364da86e

...which is indeed not translated for Hebrew.

If you want to find a specific string on Weblate I would suggest using the KeyID feature unique to LibreOffice, which is very precise for locating strings but unfortunately under-documented on our wiki right now.  Maybe others can point to better documentation about KeyID.

=> NOTABUG?

> and AFAICT that's not a recent translation. So, why has it not been carried
> forward into the release (e.g. via gerrit)?
And FWIW, the translations on Weblate are incorporated into git repo via a different process and don't go through Gerrit.
Comment 2 Xisco Faulí 2021-04-30 09:51:36 UTC
(In reply to Ming Hua from comment #1)
> (In reply to Eyal Rozenberg from comment #0)
> > If you install the Hebrew language pack for LO 7.1.0.3 and start Writer,
> > you'll notice that two of the menus, "Form" and "Table", have their English
> > names (as opposed to, say, "טופס" and "טבלה").
> > 
> > However, it seems that at least word "Form" _is_ translated on Weblate:
> Actually, no.
> 
> > https://translations.documentfoundation.org/translate/libo_ui-master/
> > officecfgregistrydataorgopenofficeofficeui/he/?checksum=a209d936575c30b1
> This is not the string for Writer's main menu (likely somewhere in Base
> because its context starts with "BaseWindowState.xcu", but I didn't
> investigate), the correct string for Writer's "Form" menu is:
> 
> https://translations.documentfoundation.org/translate/libo_ui-master/
> officecfgregistrydataorgopenofficeofficeui/he/?checksum=cbd1c0af364da86e
> 
> ...which is indeed not translated for Hebrew.
> 
> If you want to find a specific string on Weblate I would suggest using the
> KeyID feature unique to LibreOffice, which is very precise for locating
> strings but unfortunately under-documented on our wiki right now.  Maybe
> others can point to better documentation about KeyID.
> 
> => NOTABUG?

Hello Ming Hua, Thanks for the great analysis. Closing as RESOLVED NOTABUG
Comment 3 Eyal Rozenberg 2021-04-30 14:25:38 UTC
(In reply to Ming Hua from comment #1)
> https://translations.documentfoundation.org/translate/libo_ui-master/
> officecfgregistrydataorgopenofficeofficeui/he/?checksum=cbd1c0af364da86e
> 
> ...which is indeed not translated for Hebrew.

Are you sure? That looks translated as well.
Comment 4 Ming Hua 2021-04-30 14:55:29 UTC
(In reply to Eyal Rozenberg from comment #3)
> (In reply to Ming Hua from comment #1)
> > https://translations.documentfoundation.org/translate/libo_ui-master/
> > officecfgregistrydataorgopenofficeofficeui/he/?checksum=cbd1c0af364da86e
> > 
> > ...which is indeed not translated for Hebrew.
> 
> Are you sure? That looks translated as well.
Yes, but according to the history it was first translated by Weblate user @eyalroz (is that you as well?) on 20:19 2021-03-04 UTC.  And my comment was made on 07:15 2021-03-04 UTC, 13 hours before it was translated.
Comment 5 Ming Hua 2021-04-30 14:59:45 UTC
(In reply to Ming Hua from comment #4)
> Yes, but according to the history it was first translated by Weblate user
> @eyalroz (is that you as well?) on 20:19 2021-03-04 UTC.
Correction: It was suggested by @eyalroz on 03-04, but rejected one day later by @Yaron on 16:56 2021-03-05 UTC.  @Yaron provided a slightly different translation at the same time.
Comment 6 sophie 2021-04-30 15:03:36 UTC
Eyal, I suggest you install a KeyID lang pack as described here:
https://wiki.documentfoundation.org/Language#KeyID
KeyID are comments in Weblate, so searching for them made it easy to find a specific string.
Comment 7 Eyal Rozenberg 2021-04-30 15:32:05 UTC
(In reply to sophie from comment #6)
> Eyal, I suggest you install a KeyID lang pack as described here:
> https://wiki.documentfoundation.org/Language#KeyID
> KeyID are comments in Weblate, so searching for them made it easy to find a
> specific string.

I know about the KeyId pack, but it's very cumbersome to use, because it's English+KeyID. Have just opened bug 142000 about this.