Bug 140794 - Dragging the corner handle of of QR code inwards doesn't shrink proportional by definition
Summary: Dragging the corner handle of of QR code inwards doesn't shrink proportional ...
Status: RESOLVED DUPLICATE of bug 127460
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: QR-code
  Show dependency treegraph
 
Reported: 2021-03-04 11:02 UTC by Telesto
Modified: 2021-03-22 13:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (10.89 KB, application/vnd.oasis.opendocument.text)
2021-03-04 11:02 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-03-04 11:02:37 UTC
Description:
Dragging the corner handle of of QR code inwards doesn't shrink proportional by definition

Steps to Reproduce:
1. Open the attached file
2. Select QR code
3. Drag at the corner

Actual Results:
Left right/ up down are all controlled by the corner

Expected Results:
Proportional shrinking enlarging


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 385808a2dff7300ec0120fdd5e8acfad8f86e50d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 1 Telesto 2021-03-04 11:02:48 UTC
Created attachment 170208 [details]
Example file
Comment 2 Telesto 2021-03-04 11:52:40 UTC
Also in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 3 Telesto 2021-03-04 11:53:41 UTC
Also in
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 4 Telesto 2021-03-04 11:54:28 UTC
Lets include UX, because this being around forever
Comment 5 Heiko Tietze 2021-03-09 12:15:28 UTC
It's intentionally that Writer scales images proportionally while Draw doesn't, see bug 83808 and bug 90171, for example. But in fact it's the opposite for QR images, the aspect ratio is kept in Draw and not Writer. Clearly a bug, maybe easyhackable.
Comment 6 Mike Kaganski 2021-03-22 13:33:45 UTC

*** This bug has been marked as a duplicate of bug 127460 ***