Bug 140863 - Error hiding and unhiding sections
Summary: Error hiding and unhiding sections
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.1.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.3 target:7.2.0
Keywords: bibisectRequest, regression
: 141066 141230 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-07 16:37 UTC by burkhard.kasten
Modified: 2021-04-09 15:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
contains several sections. (13.22 KB, application/vnd.oasis.opendocument.text)
2021-03-07 16:39 UTC, burkhard.kasten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description burkhard.kasten 2021-03-07 16:37:03 UTC
Description:
a hidden section never can be recalled.

Steps to Reproduce:
1. open file unbenannt 1.odt
2. format sections
3. hide section karin_burkhard
4. unhide section burkhard (or any other)
5. ok.


Actual Results:
6. all sections are gone. no section can be recalled.


Expected Results:
switch off section karin_burkhard
switch on section burkhard

I use this form since many years until Version 7.0



Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 burkhard.kasten 2021-03-07 16:39:09 UTC
Created attachment 170312 [details]
contains several sections.
Comment 2 e.s. 2021-03-12 09:17:26 UTC
I also confirm this error. Hidden sections will not be visible again. 

This is a very important problem (showstopper) for the applications that use LibreOffice as a report generator or certificate generator and show/hide sections based on variable values (condition).
Comment 3 Steven Shelton 2021-03-16 14:46:12 UTC
*** Bug 141066 has been marked as a duplicate of this bug. ***
Comment 4 Steven Shelton 2021-03-16 14:47:11 UTC
Can also confirm. 

Additional:

The section also becomes hidden if you check the "Hide" box and set a condition, even if that condition is not met: If the condition is "HIDE==1", it still hides the section even if HIDE = 0.
Comment 5 Jean-Baptiste Faure 2021-03-26 09:42:22 UTC
Same problem on Linux.

Workaround to unhide an hidden section: 
1/unhide the section (it does not reappear)
2/save the document
3/reload the document via menu File > Reload => the section is visible again.

Rised the importance to High / Major because users may believe that they loose their data.

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2021-03-26 09:43:41 UTC
*** Bug 141230 has been marked as a duplicate of this bug. ***
Comment 7 Jean-Baptiste Faure 2021-03-26 10:53:42 UTC
Forgot to add the keyword regression, because that worked in previous versions.

Best regards. JBF
Comment 8 Xisco Faulí 2021-03-31 09:52:26 UTC
This issue was fixed in master by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5fc6a601d7a1978db291fd0f7dcec638a7c25651

author	Bjoern Michaelsen <bjoern.michaelsen@libreoffice.org>	2020-11-22 10:47:20 +0100
committer	Bjoern Michaelsen <bjoern.michaelsen@libreoffice.org>	2020-11-23 08:59:35 +0100
commit	5fc6a601d7a1978db291fd0f7dcec638a7c25651 (patch)
tree	a5543f8d7bc4c8012e5b922335c841313bf9ea39
parent	e4ee7fed48c540a857c49d2e32384981c9275083 (diff)
section.cxx: Remove remaining SwClientNotifyCalls

I'll try to backport it to libreoffice-7-1
Comment 9 Xisco Faulí 2021-03-31 10:03:09 UTC
this issue is only reproducible in libreoffice-7-1 branch caused by an unfortunate timing.
libreoffice-7-1 was branched off on 2020-11-22 14:58:29 and the commit was pushed on 2020-11-23 08:59:35 so the previous related commits made it to libreoffice-7-1 branch but not this one.
Comment 10 Commit Notification 2021-03-31 14:27:43 UTC
Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/296c1b3b7e2fca6d54e3e61684d70d12f7989624

tdf#140863: section.cxx: Remove remaining SwClientNotifyCalls

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-03-31 14:54:07 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b5558e4ac6c2f134f07ea87a143694b17adb4482

tdf#140863: sw: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-03-31 18:11:19 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/7932e971436870ece45a6ba75fb484e53edac7a1

tdf#140863: sw: Add UItest

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Jean-Baptiste Faure 2021-04-01 07:40:33 UTC
Thank you very much for this fix. It works as expected for me.

Best regards. JBF
Comment 14 trowelandmattock 2021-04-03 22:35:16 UTC
also much thanks! - this fixes problems which have kept me on LO6 (i.e. macros to hide/show sections in forms) - also (related?) problem with new sections on forms defaulting to a 'nested format' is gone. Love you Libre!
Comment 15 Jean-Baptiste Faure 2021-04-09 15:50:05 UTC
*** Bug 141230 has been marked as a duplicate of this bug. ***