Bug 140867 - the document language i've chosen keeps changing to USA
Summary: the document language i've chosen keeps changing to USA
Status: RESOLVED DUPLICATE of bug 136769
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-07 23:01 UTC by mango wodzak
Modified: 2021-06-12 10:47 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mango wodzak 2021-03-07 23:01:55 UTC
Not sure if this is a bug, but it seems like it.
I've changed my language for all text to Australian English.

Tools>Language>For All Text> English(Australian).

At the bottom of the doc, it clearly shows "English (Australia)" 

yet as soon as I begin typing it switches to "English (USA)" ..

I don't recall having this problem before, so it may be new to 7.1.1.2 or it could be due to my own incompetence.. In tools>options>languages I also have australian as my choice, and the same goes for the paragraph formatting, so if it's me, there must be some setting i don't know about..
Comment 1 mango wodzak 2021-03-10 21:54:03 UTC
This is strange. I closed libreoffice, and opened it again, and the issue I was having with language selection for spelling has now fully disappeared. 

Before I restarted libreoffice, I was also having troubles getting styles to be selected properly, and was about to file a bug report on that too, but after the restart, that's working fine again too.

Not sure what caused those tings, a bug somewhere for sure, but one that is clearly intermittent or a temporary glitch..

One thing which is still not working the way I expected it to, is if I select the whole document (ctrl-a), then try to change the language, using tools>Language> then all of the options (apart from "more dictionaries online") are unselectable/unclickable. 

I want to choose "For all Text" to make sure it's all in the right language, but it's not letting me do that. Is there a reason for that?
Comment 2 Timur 2021-03-11 12:05:57 UTC
Seems duplicate. Please explain if not and write your observation there if it is.

*** This bug has been marked as a duplicate of bug 136769 ***
Comment 3 Mike Kaganski 2021-06-12 10:47:03 UTC
This is unlikely to relate to tdf#133661 (or its dupe tdf#136769). The problem is reported as language dynamically changing when typing, and is most probably related to the system input language; the missing info is the OS (system input language is only honored on Windows and maybe KDE - and the "it may be new to 7.1.1.2" might be because of newly added support for the feature in KDE). It is not a bug, and works as intended; the best way to use the feature properly is set up correct input language in system; a workaround would be to "[x] Ignore system input language" under Options->Language Settings->Languages.