Bug 140930 - Crash on saving with Skia and custom shape with stretched bitmap
Summary: Crash on saving with Skia and custom shape with stretched bitmap
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2021-03-09 23:36 UTC by Regina Henschel
Modified: 2021-03-16 11:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Callstack VS2019 (7.33 KB, text/plain)
2021-03-09 23:36 UTC, Regina Henschel
Details
File with extruded custom shape (15.13 KB, application/vnd.oasis.opendocument.presentation)
2021-03-12 14:07 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2021-03-09 23:36:08 UTC
Created attachment 170385 [details]
Callstack VS2019

Start LO. Make sure Skia is enabled.
Start Impress. Insert custom shape "Regular Pentagon".
Go to Format > Object and Shape > Area.
Click on Bitmap, select a bitmap, set Style to "Stretched". OK.
Deselect shape.
Save document as .odp file. => Crash

It is an own build from today. My screen resolution is 125% = 120dpi.
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 587f4c62f632490b278197df599b225a63765c22
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-03-10 08:54:25 UTC
Not reproducible in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 3dfe1df0f1084b06c7d4c95df387253b2e058cd6
CPU threads: 4; OS: Linux 5.7; UI render: Skia/Raster; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Roman Kuznetsov 2021-03-10 09:37:39 UTC
No repro in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 72841008bf422dfd8553240b3a78f0474d03523c
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 3 Luboš Luňák 2021-03-10 11:58:12 UTC

*** This bug has been marked as a duplicate of bug 140917 ***
Comment 4 Regina Henschel 2021-03-12 14:07:31 UTC
Created attachment 170442 [details]
File with extruded custom shape

No, it is not duplicate, but might be a problem with a debug build. I do not see it with the daily build, but with both of my debug builds.

Open attached file. Select the object and rotate it a little bit. 3D-Rotating is in toolbar "3D Settings".
Then save the document _while the object is still selected_.
Comment 5 Commit Notification 2021-03-16 11:57:09 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1e9b97dc1f795da63c92b0169415a4f455d9d014

fixes for SkiaSalBitmap delayed scaling (tdf#140930)

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Luboš Luňák 2021-03-16 11:57:27 UTC
I see. Fixed.