Bug 140951 - Base crashes as soon as I start an 'Abfrage' (Windows)
Summary: Base crashes as soon as I start an 'Abfrage' (Windows)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.3.0 target:7.2.2 target:7.1.7
Keywords: haveBacktrace
: 139340 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-11 13:11 UTC by Marc Bonitz
Modified: 2021-09-07 16:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace (260.61 KB, application/pdf)
2021-03-13 17:01 UTC, Marc Bonitz
Details
bt with debug symbols (56.96 KB, text/plain)
2021-09-06 19:45 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Bonitz 2021-03-11 13:11:49 UTC
Description:
Same mistake with LO 6.4. ... and LO 7.0. ...
Base file is OK - it works on other computers

No change with safe mode or after reseting every user setting files



Steps to Reproduce:
1.open base file
2.watching tables - no problem
3.trying to start a query in designer mode (Abfrage in der Entwurfs-Ansicht) 

Actual Results:
--> it crashes immediately

Expected Results:
working with the query


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
7.0.4.2.(x64)
build dcf040e67528d9187 ....9775
Comment 1 Julien Nabet 2021-03-11 20:42:16 UTC
Which type of database do you use? Embedded type (Firebird or HSQLDB), Mysql, MariaDD, Postgresql, ODBC?

Do you reproduce this with a brand new odb file with HSQLDB embedded?

Since you got LO 64 bits, do you have Java 64 bits too? (Base part is quite dependent on Java)
Comment 2 Alex Thurgood 2021-03-12 10:11:00 UTC
Suspect that this is a DUP of bug 139340
Comment 3 Alex Thurgood 2021-03-12 10:16:28 UTC
@Marc: please advise whether you are using, or have activated, any accessibility tools or functions of Windows OS when running LibreOffice ?
Comment 4 Marc Bonitz 2021-03-12 11:08:23 UTC
(In reply to Alex Thurgood from comment #2)
> Suspect that this is a DUP of bug 139340

I checked there and the first steps and are non the wiser so far.
I unchecked OpenCL.
I unchecked the SIA rendering and restarted.
Comment 5 Marc Bonitz 2021-03-12 11:09:13 UTC
(In reply to Alex Thurgood from comment #3)
> @Marc: please advise whether you are using, or have activated, any
> accessibility tools or functions of Windows OS when running LibreOffice ?

I don't know what accessibility tools are and where to find information about it.
Comment 6 Marc Bonitz 2021-03-12 11:09:35 UTC
(In reply to Julien Nabet from comment #1)
> Which type of database do you use? Embedded type (Firebird or HSQLDB),
> Mysql, MariaDD, Postgresql, ODBC?
> 
> Do you reproduce this with a brand new odb file with HSQLDB embedded?
> 
> Since you got LO 64 bits, do you have Java 64 bits too? (Base part is quite
> dependent on Java)

Yes to all 3 questions.
Comment 7 Marc Bonitz 2021-03-12 11:10:29 UTC
HSQLDB
Comment 8 Julien Nabet 2021-03-12 20:38:12 UTC
Would it be possible you attach a backtrace?
Comment 9 Julien Nabet 2021-03-12 20:38:51 UTC
(In reply to Julien Nabet from comment #8)
> Would it be possible you attach a backtrace?

Sorry I forgot to provide a link which explains how to do this:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace
Comment 10 Marc Bonitz 2021-03-13 16:59:42 UTC
Thx for helping me.
Tried hard to figure out the backtrace thing and attach it now.
Comment 11 Marc Bonitz 2021-03-13 17:01:05 UTC
Created attachment 170458 [details]
backtrace
Comment 12 Julien Nabet 2021-03-13 18:39:29 UTC
Great job for the backtrace!
Comment 13 Xisco Faulí 2021-05-10 16:15:37 UTC
Could you please try to reproduce it with version 7.1.3.2 of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 14 Julien Nabet 2021-09-06 19:45:07 UTC
Created attachment 174832 [details]
bt with debug symbols

On Win10 with master sources updated some days ago I could reproduce this.

I had to install and enable NVDA to trigger accessibility part.
Comment 15 Julien Nabet 2021-09-06 19:47:22 UTC
Let's try with:
https://gerrit.libreoffice.org/c/core/+/121735
Comment 16 Julien Nabet 2021-09-06 19:49:31 UTC
*** Bug 139340 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2021-09-06 20:52:11 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/970883a85ad1d714683a1d98fb45efc89cbdeb3b

tdf#140951: fix crash on Base when accessibility used

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2021-09-07 10:04:16 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/b658ca65c6d5583dedec64da9b891b62d2692d49

tdf#140951: fix crash on Base when accessibility used

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2021-09-07 10:08:32 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/098c6c216af2828ab388ca61abee594f69bb5793

tdf#140951: fix crash on Base when accessibility used

It will be available in 7.1.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.