Bug 141120 - FILEOPEN: DOCX a vertical line comes out as horizontal
Summary: FILEOPEN: DOCX a vertical line comes out as horizontal
Status: RESOLVED DUPLICATE of bug 122717
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-20 02:24 UTC by Dave Gilbert
Modified: 2021-03-20 13:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
A docx with a vertical line that ends up horizontal (4.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-03-20 02:24 UTC, Dave Gilbert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gilbert 2021-03-20 02:24:39 UTC
Created attachment 170578 [details]
A docx with a vertical line that ends up horizontal

(This is split out of my comments on 118693, the fix for the rest of that doesn't fix this, but this was introduced by the same patch that caused it)

This docx has one vertical line, it loads as horizontal.
If constructing a test like this you need the line to have arrows (or in the case of this test have had arrows and removed them);
I did discuss this one on-list in Jan 2021; see 'understanding ImpForceLineAngle, aGeo and friends' (to which Regina responded) but I hadn't got much further.

In this case the hack that was added in NbcResize doesn't trigger because the width is >0 - so it still ends up recalculating the angle.
Comment 1 Timur 2021-03-20 08:09:13 UTC
Search needed before opening a bug. See bug and a duplicate.

*** This bug has been marked as a duplicate of bug 122717 ***
Comment 2 Dave Gilbert 2021-03-20 13:04:12 UTC
Thanks; for the dupe.