Bug 141166 - Crash in: mergedlo.dll: Press "Help" button in Hyperlink dialog
Summary: Crash in: mergedlo.dll: Press "Help" button in Hyperlink dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords:
Depends on:
Blocks: Hyperlink-Dialog Crash
  Show dependency treegraph
 
Reported: 2021-03-22 09:41 UTC by sdc.blanco
Modified: 2021-03-26 11:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["mergedlo.dll"]
Regression By:


Attachments
gdb backtrace (49.29 KB, text/plain)
2021-03-22 14:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2021-03-22 09:41:36 UTC
This bug was filed from the crash reporting server and is br-0d2803a4-8eb2-41b8-8221-ad9ea79abeb8.
=========================================

1. New document.
2. Insert > Hyperlink
3. Press Help button.
Crash

(both in normal and Safe mode)

Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded

and

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6e4238018bf0408f2961e5708212e09a8c3597dc
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: CL

https://crashreport.libreoffice.org/stats/crash_details/92807bc8-3ff2-4996-885a-25540fd23b3c
Comment 1 Xisco Faulí 2021-03-22 14:21:51 UTC
Reproduced in

Version: 7.0.4.2 (x86)
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-US (es_ES); UI: en-US
Calc: threaded
Comment 2 Xisco Faulí 2021-03-22 14:30:36 UTC
Created attachment 170627 [details]
gdb backtrace
Comment 3 Xisco Faulí 2021-03-22 14:31:43 UTC
I tried to bisect it but the result is not accurate.

@Caolán, any idea of what the problem might be ?
Comment 4 Xisco Faulí 2021-03-22 14:42:50 UTC
*** Bug 140539 has been marked as a duplicate of this bug. ***
Comment 5 Caolán McNamara 2021-03-22 15:50:38 UTC
I think https://gerrit.libreoffice.org/c/core/+/112920 would solve this one. I don't think 140539 is a duplicate though
Comment 6 Commit Notification 2021-03-22 20:02:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/92220638362755f0e776e222fa4e8b79377e75eb

tdf#141166 widget with id "tabcontrol" might not be a TabControl

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2021-03-22 20:05:25 UTC
done in master, backport to 7-1 and 7-0 in gerrit
Comment 8 Commit Notification 2021-03-22 20:17:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/24d11d2d0855eba28328bcefe71e923277b0aaf3

tdf#141166 widget with id "tabcontrol" might not be a TabControl

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-03-23 09:40:51 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e6efc0e309a1a715febec1e830efb1d06e3831de

tdf#141166: sw: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-03-23 10:23:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-2":

https://git.libreoffice.org/core/commit/259e17500748e2b43197bc3a96c6b0ede7e723b1

tdf#141166 widget with id "tabcontrol" might not be a TabControl

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 sdc.blanco 2021-03-26 11:35:19 UTC
VERIFIED Thanks Caolán.

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3e7e6f6fc7f8f03c6ba329c547749e3f3746c2a0
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: CL