Bug 141171 - FILESAVE: PDF: PNG images are exported as black
Summary: FILESAVE: PDF: PNG images are exported as black
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
: 141180 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-22 10:59 UTC by Xisco Faulí
Modified: 2021-05-10 16:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
How the PDF looks like (150.66 KB, application/pdf)
2021-03-22 10:59 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-03-22 10:59:33 UTC
Created attachment 170623 [details]
How the PDF looks like

Steps to reproduce:
1. Open attachment 57566 [details] from bug 46547
2. Save it to PDF

-> PNG images are black

Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5262a9e88037decc26da84e7fa62f2955d4cdb85
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-03-22 11:00:33 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e1d0846e060d2b3faedfe1a5877303037d8cf4d6

author	Luboš Luňák <l.lunak@collabora.com>	2021-03-05 19:55:43 +0100
committer	Luboš Luňák <l.lunak@collabora.com>	2021-03-12 15:37:21 +0100
commit	e1d0846e060d2b3faedfe1a5877303037d8cf4d6 (patch)
tree	c232b6fcc14b77ff1022a3bc42277c9827324d17
parent	e286bd791bfaa00746ea143303761f76e0af1f0d (diff)
drop PNGReader and use only PngImageReader

Bisected with: bibisect-linux64-7.2

Adding Cc: to Luboš Luňák
Comment 2 Xisco Faulí 2021-03-22 11:03:06 UTC
attachment 65509 [details] from bug 53452 is also affected by this issue
Comment 3 Xisco Faulí 2021-03-22 11:05:52 UTC
and attachment 72374 [details] from bug 58937
Comment 4 Xisco Faulí 2021-03-22 11:07:29 UTC
and attachment 74331 [details] from bug 60413
Comment 5 Xisco Faulí 2021-03-22 16:26:13 UTC
*** Bug 141180 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2021-03-23 09:59:49 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cd09fc9451897e6efedbf9f5e1d5b9bd96e65cb5

do not enable mbSupportsBitmap32 for headless (tdf#141171)

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-03-24 07:39:33 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/71f3980e40454907ee7e512678635eb48d9a4058

tdf#141171: vcl_pdfexport: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2021-05-10 16:01:53 UTC
Setting to VERIFIED