Bug 141172 - FILEOPEN: DOCX: missing table in endnote
Summary: FILEOPEN: DOCX: missing table in endnote
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2021-03-22 11:37 UTC by Xisco Faulí
Modified: 2021-04-13 09:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.2 master (17.17 KB, image/png)
2021-03-22 11:37 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-03-22 11:37:03 UTC
Created attachment 170624 [details]
Comparison MSO 2010 and LibreOffice 7.2 master

Steps to reproduce:
1. Open attachment from bug 76027

-> There is only one table in endnote. There should be 2. See comparison

Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5262a9e88037decc26da84e7fa62f2955d4cdb85
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-03-22 11:38:16 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7dd8f8aace536a8e60e87e61ee1d90d61fba15eb

author	László Németh <nemeth@numbertext.org>	2021-02-17 09:47:43 +0100
committer	László Németh <nemeth@numbertext.org>	2021-02-18 13:30:55 +0100
commit	7dd8f8aace536a8e60e87e61ee1d90d61fba15eb (patch)
tree	72638bfc11fa2d0ee1c55f214df3a8e027168aaa
parent	63d14566ba93b87f23a7ba68f8ea733cf19be101 (diff)
tdf#120351 DOCX import: fix slow endnote import

Bisected with: bibisect-linux64-7.2

Adding Cc: to László Németh
Comment 2 Xisco Faulí 2021-03-22 11:39:06 UTC
(In reply to Xisco Faulí from comment #0)
> Steps to reproduce:
> 1. Open attachment from bug 76027

1. Open attachment 95593 [details] from bug 76027
Comment 3 Commit Notification 2021-03-28 12:49:53 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e11c51eefe8c3210cef2b5850f401ba67a401d01

tdf#95806 tdf#125877 tdf#141172 DOCX: fix tables in footnotes

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2021-03-29 10:04:27 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 3453f2f8fce9e69cd9f2a2c6f3d7171b6e59f674
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue!!
Comment 5 László Németh 2021-04-06 08:22:47 UTC
(In reply to Xisco Faulí from comment #4)
> Verified in
> 
> Version: 7.2.0.0.alpha0+ / LibreOffice Community
> Build ID: 3453f2f8fce9e69cd9f2a2c6f3d7171b6e59f674
> CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> @László Németh, thanks for fixing this issue!!

@Xisco: thanks for the verification!

Note: there is still a limitation in the recent solution: floating table is anchored "as character", because anchoring to paragraph (which could solve the table indentation) results overlapping endnotes.