Bug 141180 - FILEOPEN: transparent image components shown as black in presentation mode (only)
Summary: FILEOPEN: transparent image components shown as black in presentation mode (o...
Status: VERIFIED DUPLICATE of bug 141171
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-03-22 15:58 UTC by Gerald Pfeifer
Modified: 2021-03-24 14:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample slides in PPTX format (610.87 KB, application/vnd.ms-powerpoint)
2021-03-22 15:58 UTC, Gerald Pfeifer
Details
Visual comparison Office 365 (left) vs LibreOffice 7.2 (right) (74.33 KB, image/png)
2021-03-22 15:59 UTC, Gerald Pfeifer
Details
ODP document exhibiting a smiliar issue (60.79 KB, application/vnd.oasis.opendocument.presentation)
2021-03-22 16:37 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2021-03-22 15:58:28 UTC
Created attachment 170633 [details]
Sample slides in PPTX format

Open the attached PPTX document in Impress and observe that where various
images contain larger portions of transparent "color" that is shown as black
instead of showing the color of the underlying background or object.

Note: This appears in presentation mode only! Edit mode is fine.


Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: b24409fce6a4f6f1848a3283258914785d4e1c10
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-03-21_13:18:03
Comment 1 Gerald Pfeifer 2021-03-22 15:59:09 UTC
Created attachment 170634 [details]
Visual comparison Office 365 (left) vs LibreOffice 7.2 (right)
Comment 2 Gerald Pfeifer 2021-03-22 16:01:32 UTC
This is a regression, the following 6.4 and 7.1 versions are okay:

Version: 6.4.8.0.0+
Build ID: 99b065ec31d032fc08ab14f66430dac4fef904a5
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-4, Time: 2020-10-08_08:57:08
Locale: en-US (en_US.UTF-8); UI-Language: en-US

Version: 7.1.3.0.0+ / LibreOffice Community
Build ID: 66319fd36564f55feb9669b3f117176f4ef4c939
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-1, Time: 2021-03-20_11:15:06
Calc: threaded
Comment 3 Xisco Faulí 2021-03-22 16:26:13 UTC
Thanks for reporting this issue.
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=e1d0846e060d2b3faedfe1a5877303037d8cf4d6 which is already reported in bug 141171. I believe the root cause is the same...

*** This bug has been marked as a duplicate of bug 141171 ***
Comment 4 Gerald Pfeifer 2021-03-22 16:37:42 UTC
Created attachment 170638 [details]
ODP document exhibiting a smiliar issue

(In reply to Xisco Faulí from comment #3)
> Regression introduced by
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=e1d0846e060d2b3faedfe1a5877303037d8cf4d6 which is already reported in
> bug 141171. I believe the root cause is the same...
> 
> *** This bug has been marked as a duplicate of bug 141171 ***

Yes, it definitely looks like this commit is it.

That was a tricky one to avoid as a duplicate: FILEOPEN vs Export as PDF,
Impress vs Writer,... :-)  I'll keep an eye on the other one and will 
validate any fixes with my documents.

Since in the meantime I had created an ODP document which exhibits a similar
issue, let me share this here and adjust the description - just in case.
Comment 5 Gerald Pfeifer 2021-03-24 13:35:03 UTC
I verified that now that bug#141171 is fixed, this is fixed, too.

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: bdbb5d0389642c0d445b5779fe2a18fda3e4a4d4
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time: 2021-03-24_01:37:05

Should I mark this VERIFIED in this specific case (given how different
it is - Impress vs Writer, Presentation Mode vs PDF Expert)?
Comment 6 Xisco Faulí 2021-03-24 14:21:47 UTC
(In reply to Gerald Pfeifer from comment #5)
> I verified that now that bug#141171 is fixed, this is fixed, too.
> 
> Version: 7.2.0.0.alpha0+ / LibreOffice Community
> Build ID: bdbb5d0389642c0d445b5779fe2a18fda3e4a4d4
> CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time:
> 2021-03-24_01:37:05
> 
> Should I mark this VERIFIED in this specific case (given how different
> it is - Impress vs Writer, Presentation Mode vs PDF Expert)?

Yes, the DUPLICATE of can also be set to VERIFIED