Bug 141238 - Clicking on Paste down arrow icon crashes Writer
Summary: Clicking on Paste down arrow icon crashes Writer
Status: RESOLVED DUPLICATE of bug 141141
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-03-24 19:11 UTC by medmedin2014
Modified: 2021-03-27 14:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Paste down arrow button (15.57 KB, image/png)
2021-03-24 19:11 UTC, medmedin2014
Details
Corrected - Pase down arrow button (17.19 KB, image/png)
2021-03-24 19:14 UTC, medmedin2014
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medmedin2014 2021-03-24 19:11:40 UTC
Created attachment 170721 [details]
Paste down arrow button

When you open Writer and click on the down arrow in Paste button (see attached image), Writer crashes.
https://crashreport.libreoffice.org/stats/crash_details/8ea828b9-87cb-4418-8e7a-bc24e0c87483

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 4566bcbf03c1b7b0c1ce3a83fee1d195f0ff7059
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-03-22_14:46:06
Calc: threaded

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.4.105-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Comment 1 medmedin2014 2021-03-24 19:13:34 UTC Comment hidden (obsolete)
Comment 2 medmedin2014 2021-03-24 19:14:37 UTC
Created attachment 170722 [details]
Corrected - Pase down arrow button
Comment 3 Roman Kuznetsov 2021-03-26 20:32:42 UTC
Confirm in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 07996bcca53939af02921a3d4681c6c7d62a0e40
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL

but not in 7.1.1.2 => regression

I bisected it with win-7.2 bisect repo and got a sha
 c25f4b4db367ab66702e83bf27c2561cc7d0e5f9

https://gerrit.libreoffice.org/c/core/+/111358

https://git.libreoffice.org/core/commit/c25f4b4db367ab66702e83bf27c2561cc7d0e5f9

Added to CC: Caolan McNamara
Comment 4 Julien Nabet 2021-03-27 08:11:12 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this only if I use non standard view, for example tabbed view.
Is it the same for you too?
Indeed, I think it might be a dup of tdf#141141 put in see also.
Comment 5 Aron Budea 2021-03-27 14:40:36 UTC
Right, it looks like a duplicate to me, too.

*** This bug has been marked as a duplicate of bug 141141 ***