Bug 141309 - FILEOPEN XLSX Autofiltered time values do not appear in autofilter
Summary: FILEOPEN XLSX Autofiltered time values do not appear in autofilter
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.2.0
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Autofilter
  Show dependency treegraph
 
Reported: 2021-03-29 06:44 UTC by NISZ LibreOffice Team
Modified: 2021-06-01 09:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel (8.75 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-03-29 06:44 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc (152.38 KB, image/png)
2021-03-29 06:44 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-03-29 06:44:00 UTC
Created attachment 170800 [details]
Example file from Excel

Attached file contains some time values that were autofiltered in Excel.
When opened in Calc the autofilter dropdown shows all values as hidden, while only some were hidden in Excel.

Steps to reproduce:
    1. Open attached file

Actual results:
The autofilter displays all values as unchecked.
The main sheet however displays the filtering results correctly.

Expected results:
Only values from 12:xx hours should be unchecked in the filter.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: bdbb5d0389642c0d445b5779fe2a18fda3e4a4d4
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

Also happens in 6.0, 5.0, 4.0
Comment 1 NISZ LibreOffice Team 2021-03-29 06:44:22 UTC
Created attachment 170801 [details]
Screenshot of the original document side by side in Excel and Calc
Comment 2 NISZ LibreOffice Team 2021-03-29 07:13:31 UTC
Note: this seems to be locale-dependent too: 
- happens with en-US
- does not happen with hu-HU
Comment 3 Xisco Faulí 2021-03-29 08:09:41 UTC
Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 3e4eb070787d4d44b3bdc95046e5b231dbbef42b
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Commit Notification 2021-05-27 11:05:03 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6a2060cef22b19dbe04676c8c16776c4693b4dd8

tdf#141309 tdf#142215 OOXML import: fix double conversion in autofilter

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 BogdanB 2021-06-01 09:10:53 UTC
It's fixed now. Thanks for your work.

Verified in
Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: f49e5902a3737c02fabf5bec23243ccb126426c4
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded