Bug 141330 - FILEOPEN DOCX: Horizontal line has wrong size/position
Summary: FILEOPEN DOCX: Horizontal line has wrong size/position
Status: RESOLVED DUPLICATE of bug 141540
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OOXML-Shapes Regress-elim-SvxShapePolyPolygonBezier
  Show dependency treegraph
 
Reported: 2021-03-29 21:17 UTC by Aron Budea
Modified: 2021-05-06 14:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison LibreOffice 7.2 master and MSO 2010 (86.52 KB, image/png)
2021-03-30 13:07 UTC, Xisco Faulí
Details
Compare Word with LO daily 03 May (64.56 KB, image/png)
2021-05-06 14:34 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2021-03-29 21:17:52 UTC
This is a follow-up to bug 122717.

Attachment 148320 [details] (from bug 122717) is a DOCX created in Word, and has two crossing lines (like a +, see attachment 170789 [details]).

When opened in Writer, now it looks more like a † shape (see attachment 170790 [details] for comparison between latest 7.2 and 6.1).
This is after bug 122717's fix, before that it looked like a | shape, with the horizontal line only shown as a dot.
Before 6.2 the shape looked correct.

Regressing commit in 6.2:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=36bade04d3780bc54c51b46bb0b63e69789658a5
author		Armin Le Grand <Armin.Le.Grand@cib.de>	2018-06-28 19:48:59 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-07-02 18:03:44 +0200

"tdf106792 Get rid of SvxShapePolyPolygonBezier"

Fixing commit in 7.2 resulting in the current view:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=3e4eb070787d4d44b3bdc95046e5b231dbbef42b
author		Xisco Fauli <xiscofauli@libreoffice.org>	2021-03-25 17:38:20 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2021-03-26 09:10:17 +0100

"tdf#122717: fix handling of zero width/height lines"
Comment 1 Xisco Faulí 2021-03-30 13:07:58 UTC
Created attachment 170831 [details]
Comparison LibreOffice 7.2 master and  MSO 2010
Comment 2 Regina Henschel 2021-05-06 14:34:42 UTC
Created attachment 171701 [details]
Compare Word with LO daily 03 May

I see no difference between Word and LO daily.

I have used Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c930c4f3109d123c0831d0fcecf9c8b32e5bbc7
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 3 Xisco Faulí 2021-05-06 14:52:38 UTC
Yes, issue fixed by

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2a70cfb09c4d89154d229b6a95cf076e8bd76798

author	Regina Henschel <rb.henschel@t-online.de>	2021-04-11 13:03:27 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2021-04-22 10:12:32 +0200
commit 2a70cfb09c4d89154d229b6a95cf076e8bd76798 (patch)
tree 1b77568a3a80390046a685e794fce267ec35835d
parent 1b1a9c6c12ebe4cac19e34ff5e4818998bbb2537 (diff)
tdf#141540 fix docx import of group or line with rotation

@Regina, thanks for fixing this issue. Closing as duplicate of bug 141540

*** This bug has been marked as a duplicate of bug 141540 ***