Bug 141379 - Crash triggered while opening specific docx file
Summary: Crash triggered while opening specific docx file
Status: RESOLVED DUPLICATE of bug 140668
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-31 05:34 UTC by michal
Modified: 2021-03-31 08:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File that crashes Writer (101.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-03-31 05:36 UTC, michal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description michal 2021-03-31 05:34:27 UTC
Description:
LibreWriter crashes every time I open the attached docx file, while the file can be correctly opened in MS Office.

Steps to Reproduce:
1. Open file attached to this bug report.


Actual Results:
Crash.

Expected Results:
File is opened in Writer.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.1.1.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: cs-CZ
7.1.1-1
Calc: threaded
Comment 1 michal 2021-03-31 05:36:07 UTC
Created attachment 170848 [details]
File that crashes Writer
Comment 2 steve 2021-03-31 07:30:12 UTC
Reproduced on
Version: 7.1.1.2 / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded
(file does not open, LO goes into recovery mode, click ok, repeat)

Not reproduced with master so appears problem is already fixed in
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 8940975262a98dc1087712e366f595289ac650b3
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

@Michal: Could you install LibreOffice nightly build and see if the problem persists using that build:
https://dev-builds.libreoffice.org/daily/master
Comment 3 Xisco Faulí 2021-03-31 08:13:18 UTC
Thanks for reporting this issue.
This was fixed by https://git.libreoffice.org/core/+/027cc8c90badd4dd8a3436d859587c1b8732459f%5E%21 and it will be fixed in LibreOffice 7.1.2.2, due to be released this week.
Closing as duplicate of bug 140668

*** This bug has been marked as a duplicate of bug 140668 ***