Bug 141435 - Cropped images +75PPP lose their aspect ratio after having been compressed
Summary: Cropped images +75PPP lose their aspect ratio after having been compressed
Status: RESOLVED DUPLICATE of bug 83734
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
: 143151 (view as bug list)
Depends on:
Blocks: Image-DPI
  Show dependency treegraph
 
Reported: 2021-04-01 17:03 UTC by rafael.linux.user
Modified: 2022-11-23 20:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Upper images: Orignal cropped Bottom images: Original cropped after compression (1.95 MB, application/vnd.oasis.opendocument.text)
2021-04-01 17:03 UTC, rafael.linux.user
Details
Screenshot after compress bottom row images (312.31 KB, image/jpeg)
2021-04-27 18:46 UTC, rafael.linux.user
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rafael.linux.user 2021-04-01 17:03:59 UTC
Created attachment 170904 [details]
Upper images: Orignal cropped  Bottom images: Original cropped after compression

1 - Create a document and insert a JPG or PNG image with a dpi > 75dpi (more higher, more visible is the issue)
2 - Crop image only vertically or horizontally at half size
3 - Compress image

Result: Image is compressed but it lost aspect ratio. I think is a calculation error inside compress process
Comment 1 Dieter 2021-04-26 08:55:51 UTC
I can't confirm it with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 15a9bee9ef26ce13ed1e26319306a88b6d886158
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

and also not with

Version: 7.1.3.1 (x64) / LibreOffice Community
Build ID: fa76d07d7006a0e2866c3247cef2d5eb55ae8369
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

I openeed attached document but for every image aspect ratio looks O. K.
Comment 2 rafael.linux.user 2021-04-27 18:41:29 UTC
You must compress the original (upper row) tiger photo to see the issue. Just when you do it, image will appear narrowed horizontally.
Comment 3 rafael.linux.user 2021-04-27 18:46:35 UTC
Created attachment 171464 [details]
Screenshot after compress bottom row images
Comment 4 Telesto 2021-04-27 20:16:44 UTC
There might be a similar bug in meta bug 116082 (it also depends on screen resolution. Which screen used to create & which screen used to compress)..
Comment 5 Dieter 2021-05-09 14:54:36 UTC
(In reply to rafael.linux.user from comment #2)
> You must compress the original (upper row) tiger photo to see the issue.
> Just when you do it, image will appear narrowed horizontally.

O. K. Now I could see it (it wasn't as a much as I expected). I changed DPI from 300 to 150


Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 15a9bee9ef26ce13ed1e26319306a88b6d886158
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 6 Buovjaga 2021-07-17 14:20:01 UTC
*** Bug 143151 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2021-08-10 18:41:45 UTC
Checked with bibisect repos and this is there since 4.1, so same as bug 83734. I understand that Mike didn't close as duplicate because there is some difference in the bug descriptions.
Comment 8 Stéphane Guillou (stragu) 2022-11-23 20:47:00 UTC
I think we can confidently close as a dupe of bug 83734.

*** This bug has been marked as a duplicate of bug 83734 ***