Bug 141453 - Better integration of outline numbering with paragraph and numbering styles
Summary: Better integration of outline numbering with paragraph and numbering styles
Status: RESOLVED DUPLICATE of bug 62032
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2021-04-02 09:39 UTC by Eyal Rozenberg
Modified: 2021-11-21 08:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2021-04-02 09:39:45 UTC
It is relatively common for users to want to associate multi-level numbering with heading levels.

A lay user of LibreOffice wishing to do this would try to go through either the paragraph style of the headings, or through a (multilevel) numbering style. But this will not quite work out. The feature _does_ exist in LO - but it is hidden away as "Tools | Chapter Numbering". And a user, novice or advanced, has very little or no chance to :

1. Decide there should be some extra numbering functionality which surely must exist, and go look for it outside the Style dialogs.
2. Look for it in the Tools menu.
(3. Decide that "Chapter Numbering" is what they are after.)

As for (3), that's the subject of bug 141452, so let's forget about the naming for now. (1) + (2) are bad enough.

One could argue "Ok, but we have this configured properly by default! Heading N is set to outline (numbering) level N" - but this goes away once a user decides to apply a different numbering scheme: They would either create one using the List styles pane, or using Format | Bullets and Numbering, then update the heading style with it applied, and the outline level will be/may be lost.

---

Not only is the UI for this functionality hidden away, but there is also a weird dis-integration or "dis-associated" of the functionality and the UI for:

* Working with multi-level numbering styles/schemes
* Controlling paragraph style <-> outline level association
* Controlling paragraph style <-> multi-level numbering association + a single multi-level numbering scheme which supports this association, and only has part of the settings of other numbering schemes

This seems broken and confusing.

* Why can't we have multiple paragraph-style-linked numbering schemes?
* Why shouldn't the numbering styles/schemes be viewable and configurable via the (List) Styles pane?
* Why should the dialog for configuring Numbering styles not simply allow for levels to be associated with paragraph styles and/or outline levels?

Note: Bug 104151 suggested the minor change of moving "Outline Numbering" to the Style menu. While that would have been somewhat of an improvement in terms of discoverability, it would not have helped the more fundamental problem.
Comment 1 Eyal Rozenberg 2021-04-02 09:59:11 UTC
One approach to resolving this issue (partially or fully) is the suggestion in bug 62032. See also the discussion in the dupe bug 104206.
Comment 2 Heiko Tietze 2021-04-26 07:47:11 UTC
(In reply to Eyal Rozenberg from comment #1)
> One approach to resolving this issue (partially or fully) is the suggestion
> in bug 62032. See also the discussion in the dupe bug 104206.

And why do you need another ticket? There are likely more of this kind.
Comment 3 Eyal Rozenberg 2021-04-26 14:10:37 UTC
(In reply to Heiko Tietze from comment #2)
> And why do you need another ticket? There are likely more of this kind.

Because that ticket's suggestion is not necessarily one I support, and would certainly not resolve the entire issue, as I have laid it our in the opening comment.
Comment 4 Heiko Tietze 2021-04-27 10:00:48 UTC
(In reply to Eyal Rozenberg from comment #0)
> * Why can't we have multiple paragraph-style-linked numbering schemes?
> * Why shouldn't the numbering styles/schemes be viewable and configurable
> via the (List) Styles pane?
> * Why should the dialog for configuring Numbering styles not simply allow
> for levels to be associated with paragraph styles and/or outline levels?

Many answers are given on bug 104206 which is a duplicate itself of bug 62032 (would do the same for this one). The confusion has been reported in bug 83071 or bug 96274. And we introduced a tooltip as first band aid in bug 122637.

=> DUP of 62032 (keep in mind that QA works on numbers; the priority of tickets raise with duplicates and people on CC)
Comment 5 Justin L 2021-05-01 07:56:07 UTC
I also don't see any reason to keep this as a separate bug (regardless of bug 62032 comment 5 / bug 62032 comment 29).

*** This bug has been marked as a duplicate of bug 62032 ***