Bug 141481 - NAVIGATOR: F5 should open navigator in sidebar deack instead of floating window
Summary: NAVIGATOR: F5 should open navigator in sidebar deack instead of floating window
Status: RESOLVED DUPLICATE of bug 84502
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2021-04-03 21:15 UTC by Jeff Fortin Tam
Modified: 2021-04-19 07:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Fortin Tam 2021-04-03 21:15:46 UTC
Here's something that has always confused me in the way the Navigator behaves. When you press the F5 key to show/hide it, it behaves totally differently from the others like the stylist (F11). F11 always toggles the visibility of the sidebar (or floating window) containing the stylist (or switches to the stylist in the sidebar), but F5 always the navigator as a "second sidebar"... and when you have a docked sidebar currently shown, F5 creates another sidebar to show the navigator instead of switching the view of the already shown sidebar.

So it ends up looking fairly messy like the screenshot you see in attachment #170942 [details].

To me, it would make more sense if F5 toggled on the visibility of the sidebar (and switches to the navigator section of it, if it was not already shown), just like F11 does for the stylist. *If* the sidebar was undocked then in that case yes I "could" imagine the navigator being its own secondary sidebar, but otherwise it's just stacking multiple sidebars in a weird interaction pattern.
Comment 1 Dieter 2021-04-18 10:55:13 UTC
I agree with this expectation. Decision is up to design team
Comment 2 Roman Kuznetsov 2021-04-18 11:03:44 UTC
We already discussed this many times. We need a different Navigator window/pane. A simple example - I use Navigator and Styles pane in one time!

My point is WONTFIX
Comment 3 Dieter 2021-04-18 11:14:11 UTC
But it should at least be possible to customise F5. But I couldn't find a command for opening navigator in sidebar (but perhaps there is one)
Comment 4 Roman Kuznetsov 2021-04-18 11:26:55 UTC
(In reply to Dieter from comment #3)
> But it should at least be possible to customize F5. 

It will be a good solution for the "problem" here
Comment 5 V Stuart Foote 2021-04-18 13:47:47 UTC
Jim R. has https://gerrit.libreoffice.org/c/core/+/100455 up for bug 84502

It will provide users direct shortcut access (user customizable) to the decks of the Sidebar.  

And eventually we'd still benefit from extension of the Sidebar framework to allow detached decks bug 85905, though by then the F5 / F11 paradigm for a Navigator & Stylist panel open will have become less commonly used.

*** This bug has been marked as a duplicate of bug 84502 ***
Comment 6 Heiko Tietze 2021-04-19 07:36:13 UTC
See also bug 85850 - ctrl+F5 toggles the sidebar similar to F5 for the Navigator.
Comment 7 Dieter 2021-04-19 07:53:31 UTC
(In reply to Heiko Tietze from comment #6)
> See also bug 85850 - ctrl+F5 toggles the sidebar similar to F5 for the
> Navigator.

Documentation about that is missing (see bug 141756)