Bug 141514 - Fileopen of RT XLSX with autofilter crashes 64-bit LO from 7.2+ (only Windows 7? )
Summary: Fileopen of RT XLSX with autofilter crashes 64-bit LO from 7.2+ (only Windows...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:xlsx, regression
Depends on:
Blocks:
 
Reported: 2021-04-06 12:34 UTC by Timur
Modified: 2021-05-28 09:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
XLSX saved with Lo 7.2+ and then with MSO (12.20 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-04-07 06:31 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2021-04-06 12:34:40 UTC
Open ODS attachment 134862 [details] from bug 109374.
Save as XLSX. Close. 
Reooen XLSX. Crash. 

Repro Windows LO 7.2+. Not with 7.1.0 so looks regression. No repro Linux. 

Saved XLSX looks OK with MSO, no autofilter bug like XLS.
Comment 1 Timur 2021-04-06 12:51:23 UTC
LO also crashes if that XLSX is resaved in MSO. So it looks like fileopen bug.
Comment 2 Xisco Faulí 2021-04-06 13:02:12 UTC Comment hidden (obsolete)
Comment 3 Timur 2021-04-06 13:50:14 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2021-04-06 13:55:32 UTC
(In reply to Timur from comment #3)
> Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
> Build ID: c7cfd3323cf80d5953f5c3808c1afd6fec0c674b
> CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render:
> Skia/Raster; VCL: win
> Locale: bs-BA (bs_BA); UI: en-US
> Calc: CL

I can't reproduce it in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c7cfd3323cf80d5953f5c3808c1afd6fec0c674b
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

notice i'm using the same exact build as you.
please, add the XLSX you generated. Also try with multi-threading calculation...
Comment 5 Timur 2021-04-06 14:43:13 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2021-04-06 15:01:45 UTC
No crash

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6b3f0866e9eddd5553857741862ca0d7d5b2ec2b
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: fi-FI
Calc: threaded
Comment 7 Timur 2021-04-07 06:27:23 UTC
Repro with different threaded abd OpenCL options. 
I guess my saved XLSX can't help, because it doesn't crash with 7.1.
Can't figure out what would be the catch. 
I tried on that computer with fresh profile, the same crash.
I'm adding prominent folks here, thanks for testing and feel free not to if you don't feel like.
Comment 8 Timur 2021-04-07 06:31:17 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2021-04-07 06:43:10 UTC
Timur: as we now have Win debug builds Win-x86@39 again, could you try getting a backtrace of the crash? https://dev-builds.libreoffice.org/daily/master/current.html

https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 10 Xisco Faulí 2021-04-07 07:00:53 UTC
lowering priority until this issue is sorted out. it can be bumped later on
Comment 11 Timur 2021-04-07 07:17:06 UTC
No crash with x86, just x64. 
Interesting that Procdump doesn't register the crash, says "Dump count not reached". 

And I wouldn't say it's broken installation, I had it from 30.03. and later from 06.4.,both crashed.It's parallel instalation but 7.1 that doesn't crash is the same.
Comment 12 Timur 2021-04-07 07:44:55 UTC
If XLSX saved with autofilter but not filtering applied, no crash. 
If filter set to All and again applied, crash. So it's autofilter related.
Comment 13 Timur 2021-04-07 09:55:54 UTC
(In reply to Timur from comment #8)
> Created attachment 170989 [details]
> XLSX saved with Lo 7.2+ and then with MSO

Another sample is MSO XLSX attachment 167138 [details] from bug 138089. Crash on open.
Comment 14 NISZ LibreOffice Team 2021-04-07 13:33:47 UTC
No crash for me either with fresh bibisect-7.2 (updated yesterday):

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: da6c70efbc991f1fc61aace267dd4f972dedce6c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

* Saving the example file from comment #1 - works, 
* Resaving the xlsx with Excel 19 and opening it - works, 
* Opening the example file from comment #13 - works.
Comment 15 Peter S Anderson 2021-04-07 23:03:48 UTC
No crash for me this morning on 7.2 build ea4fb1559f7b99a0bfaf18f26cb3b6972c9cde1c 
Windows 10.0 Build 19042
Comment 16 Timur 2021-04-08 05:04:02 UTC Comment hidden (obsolete)
Comment 17 Timur 2021-04-08 05:05:51 UTC
Could be that it's Windows 7 only.
Comment 18 Timur 2021-04-08 11:58:07 UTC
After so many no repros, I downloaded Windows bisect repo and also no repro. 
No explanation, but I'll close. 
Thanks.
Comment 19 Roman Kuznetsov 2021-04-09 21:30:37 UTC
so late but anyway, no repro in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7c6605bd2c1b27c12c4a492921e537eb4bf5a98e
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL
Comment 20 Timur 2021-05-28 08:56:24 UTC
No repro anymore.
Comment 21 Xisco Faulí 2021-05-28 09:01:47 UTC
(In reply to Timur from comment #20)
> No repro anymore.

Hi Timur,
Please bisect the fix