Bug 141558 - DOCX: FILESAVE: Lost Russian list numbering type
Summary: DOCX: FILESAVE: Lost Russian list numbering type
Status: RESOLVED DUPLICATE of bug 97569
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2021-04-08 08:33 UTC by Roman Kuznetsov
Modified: 2021-04-09 06:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT example with Russian list numbering type (8.65 KB, application/vnd.oasis.opendocument.text)
2021-04-08 08:34 UTC, Roman Kuznetsov
Details
DOCX by MS Word with Russian letter numbering (12.73 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-04-08 17:30 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2021-04-08 08:33:00 UTC
Description:
DOCX: FILESAVE: Lost Russian list numbering type

Steps to Reproduce:
1. Open ODT file from attach
2. Save it to DOCX
3. Reopen DOCX
4. Look at list numbering type => it became
 
1
2
3
4
5 

instead 

а
б
в
г
д

Actual Results:
We lost Russian list numbering type after save to DOCX

Expected Results:
We still have Russian list numbering type after save to DOCX


Reproducible: Always


User Profile Reset: No



Additional Info:
still rerpo in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7d6e12c01e6c1dd050818a2ea76faa6bf89e41f1
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

and I checked in 5.2.7 too
Comment 1 Roman Kuznetsov 2021-04-08 08:34:17 UTC
Created attachment 171026 [details]
ODT example with Russian list numbering type
Comment 2 Roman Kuznetsov 2021-04-08 08:37:25 UTC
Justin, I thought you will be interested in this bug
Comment 3 Xisco Faulí 2021-04-08 09:27:39 UTC
Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 78eaf6489a6542378ffab7eef39ec0a2c5f1a10a
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

and

Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311
Locale: en_US
Comment 4 Timur 2021-04-08 12:38:20 UTC
Looks duplicate.

*** This bug has been marked as a duplicate of bug 97569 ***
Comment 5 Justin L 2021-04-08 15:26:59 UTC
What I really need is an MS Word DOCX that contains Russian list numbering. Is that possible?  (bug 97569 suggests the answer is no.)
Comment 6 Roman Kuznetsov 2021-04-08 17:30:04 UTC
Created attachment 171036 [details]
DOCX by MS Word with Russian letter numbering
Comment 7 Roman Kuznetsov 2021-04-08 17:30:55 UTC
(In reply to Justin L from comment #5)
> What I really need is an MS Word DOCX that contains Russian list numbering.
> Is that possible?  (bug 97569 suggests the answer is no.)

Justin, try DOCX from attach, I created it in MS Word 2016
Comment 8 Justin L 2021-04-08 18:26:39 UTC
OK - great. So in Word's numbering.xml we have w:numFmt w:val="russianLower" and in LO we have style:num-format="а, б, .., аа, аб, ... (ru)" (kinda strange). That should map to CHARS_CYRILLIC_LOWER_LETTER_RU and CHARS_CYRILLIC_LOWER_LETTER_N_RU

Word's documentation also references russianUpper.
Comment 9 Roman Kuznetsov 2021-04-08 20:13:09 UTC
(In reply to Justin L from comment #8)
 
> Word's documentation also references russianUpper.

Yeah, I see two variants for russian letters in the Numbering dialog in Word. One is А,Б,В and second is а,б,в
Comment 10 Justin L 2021-04-09 06:14:39 UTC
Proposed fix at https://gerrit.libreoffice.org/c/core/+/113829