Bug 141704 - FILEOPEN PPTX Internal links used in interactions are not imported
Summary: FILEOPEN PPTX Internal links used in interactions are not imported
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.3.0
Keywords: filter:pptx
: 91643 112944 (view as bug list)
Depends on:
Blocks: PPTX-Hyperlink
  Show dependency treegraph
 
Reported: 2021-04-15 13:27 UTC by NISZ LibreOffice Team
Modified: 2021-10-05 09:22 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from PowerPoint with internal hyperlinks on images (55.15 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-04-15 13:27 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in PowerPoint and Impress (98.17 KB, image/png)
2021-04-15 13:27 UTC, NISZ LibreOffice Team
Details
Another example file with images and interaction links on them (55.15 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-09-20 06:59 UTC, NISZ LibreOffice Team
Details
the attachment 175128 in PP and current nightly (133.50 KB, image/png)
2021-09-20 07:01 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-04-15 13:27:18 UTC
Created attachment 171220 [details]
Example file from PowerPoint with internal hyperlinks on images

This is the import side of bug #54037
When a PPTX slideshow contains internal hyperlinks used in interactions pointing to the first/last and previous/next etc slides, these are not imported by Impress.

Steps to reproduce:
    1. Open attached file.
    2. Start the slideshow and try clicking on the image on each slides

Actual results:
Hyperlinks were not imported so nothing happens.
These should be editable in the right click menu – Interactions dialog, which also indicates there is nothing associated to the images.

Expected results:
Clicking the image on the first slide should take to the last slide.
Clicking the image on the second slide should take to the next slide.
Clicking the image on the third slide should take to the previous slide.
Clicking the image on the fourth slide should take to the second slide.
Clicking the image on the fifth slide should take to the first slide.
Clicking the image on the sixth slide should end the slideshow.
Clicking the image on the seventh slide should take to the last viewed slide.

PP also supports some other interaction types such as running a program or macro or object event, these are not requested here.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 77419c6f3aba1fd5b1660795923c22a39bdb1bad
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-04-15 13:27:44 UTC
Created attachment 171221 [details]
Screenshot of the original document side by side in PowerPoint and Impress
Comment 2 Xisco Faulí 2021-04-22 10:18:34 UTC
Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 93bb5fcba9e58eeeaaed9521c3bb4eecf9b91ac1
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Timur 2021-05-06 07:24:27 UTC
PPTX fileopen was in bug 65724 and there was a fix with some improvement.
Dev opted to close that one so I first put remaining to unresolved duplicate bug 112944.
Now I see this one, I'll mark bug 112944 a duplicate (earlier but not well defined) and write here a situation with PPTX attachment 80789 [details] in 7.2+ after the fix.
Also duplicated bug 91643 wasn't resolved, so I reopened. It's also similar, I'll duplicate to this one.

attachment 80789 [details] Edit mode:
Title page OK (with links after the fix), 1st page > 3rd page NOK, 1st > Title OK, 2nd > Title OK, 2nd > Last OK
attachment 80789 [details] Presentation mode:
Title page OK (links were partially working, also seen now), 1st page > 3rd page OK (as before), 1st > Title NOK (doesn't work immediately but can work after a few clicks), 2nd > Title NOK, 2nd > Last NOK
Comment 4 Timur 2021-05-06 07:24:57 UTC
*** Bug 112944 has been marked as a duplicate of this bug. ***
Comment 5 Timur 2021-05-06 07:25:21 UTC
*** Bug 91643 has been marked as a duplicate of this bug. ***
Comment 6 NISZ LibreOffice Team 2021-05-06 13:18:14 UTC
(In reply to Timur from comment #3)
> attachment 80789 [details] Presentation mode:
> Title page OK (links were partially working, also seen now), 1st page > 3rd
> page OK (as before), 1st > Title NOK (doesn't work immediately but can work
> after a few clicks), 2nd > Title NOK, 2nd > Last NOK

Thanks for sorting out the older duplicates!

This problem with text links not working in presentation mode (despite working in the editor) was filed as separate bug #141789
Comment 7 BogdanB 2021-07-31 08:09:09 UTC
Also in
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 5aa74aa1e6fac571f99146ebcb6adc9feb1459ad
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-07-28_19:35:14
Calc: threaded
Comment 8 Commit Notification 2021-09-14 13:23:54 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9bb91441b46d677860530d8bf9597c96561a1b0a

tdf#141704 PPTX import: fix hyperlinks on images

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 NISZ LibreOffice Team 2021-09-20 06:59:51 UTC
Created attachment 175128 [details]
Another example file with images and interaction links on them

So apparently there is a little bit of difference between how images are added to a slide:
- the images in attachment 171220 [details] were added by using the image placeholder. Interaction links on such are still not imported.
- the images in this attachment were added using Insert - Images. Interaction links on such are now imported correctly.
Comment 10 NISZ LibreOffice Team 2021-09-20 07:01:42 UTC
Created attachment 175129 [details]
the attachment 175128 [details] in PP and current nightly

This is working correctly now in:

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 770dcb1f717d576facf31efed14bee403e1a7155
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 11 NISZ LibreOffice Team 2021-09-20 07:27:25 UTC
Let me reopen this until the original attachment starts to import fine.
Comment 12 Commit Notification 2021-09-27 15:05:25 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6e200689eb309cdbe1e4f08311a400835de19bfb

tdf#141704 PPTX import: fix hyperlinks on images added via placeholder

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 NISZ LibreOffice Team 2021-10-05 09:22:41 UTC
Verified in:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c2de581d1943df2d84f2b71817b6a8bee41f0217
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL