Bug 141715 - incorrect horizontal scaling of glyphs in sm formula nodes
Summary: incorrect horizontal scaling of glyphs in sm formula nodes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: regression
: 140940 140974 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2021-04-16 16:18 UTC by Dorange-Pattoret Didier
Modified: 2021-04-23 22:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a sm panel with the widevec and widehat glyphs scaled incorrectly with Skia rendering (23.39 KB, image/png)
2021-04-17 15:11 UTC, V Stuart Foote
Details
wrong vectors and wrong hats (9.33 KB, application/pdf)
2021-04-20 07:24 UTC, Dorange-Pattoret Didier
Details
Wait I see in writer (9.41 KB, image/png)
2021-04-20 07:32 UTC, Dorange-Pattoret Didier
Details
Arrows smooth enough ? (20.76 KB, image/png)
2021-04-22 16:11 UTC, Dorange-Pattoret Didier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dorange-Pattoret Didier 2021-04-16 16:18:11 UTC
Description:
An error comes when a try to insert a vector under LO 7.1.2
The bugs does not come with lower versions like 7.1.1 or 7.1.0

Steps to Reproduce:
1. open a writer document
2. follow insert a formula
3. write widevec {AB}
The problem comes with widehat {ABC} etc ...

Actual Results:
A vector without arrow but line on the right side 

Expected Results:
A correct vector


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: threaded

Same problem with Win 10.
Comment 1 Julien Nabet 2021-04-17 07:49:03 UTC
Just for the record, on pc Debian x86-64 with master sources updated today + gen rendering (to try to be nearer from Windows), I don't reproduce this.
Perhaps Windows only bug.
Comment 2 Dorange-Pattoret Didier 2021-04-17 08:21:03 UTC
Hello,
The bug does'nt come under Linux Ubuntu, only Windows.
Comment 3 Dorange-Pattoret Didier 2021-04-17 08:59:46 UTC
No problem with MacOSX.

It's a regression from LO 7.1.1 to LO 7.1.2 under Windows.

Please try to fix this bug

Thanks in advance.
Comment 4 [REDACTED] 2021-04-17 09:19:36 UTC
Repro:
  
Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 1; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: en-US
Calc: threaded


No repro:

Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 1; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: en-US (en_DE); UI: en-US
Calc: threaded


=> Problem is with Skia.
Comment 5 Julien Nabet 2021-04-17 10:19:33 UTC
Thank you Uwe for the feedback, let's put it at NEW then.
Comment 6 V Stuart Foote 2021-04-17 15:10:00 UTC
The calculated node for the widehat and the widevec are correct. Just the glyphs are being scaled incorrectly and extend beyond the node bounds. Only with Skia rendering--looks to be in just the X-axis for scaling the font to fit the node.

Believe this is the same issue as bug 140940

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 807d059d99e7b99fe45a712428befa17ffa44858
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 7 V Stuart Foote 2021-04-17 15:11:05 UTC
Created attachment 171256 [details]
a sm panel with the widevec and widehat glyphs scaled incorrectly with Skia rendering
Comment 8 Dorange-Pattoret Didier 2021-04-20 07:24:19 UTC
Created attachment 171299 [details]
wrong vectors and wrong hats
Comment 9 Dorange-Pattoret Didier 2021-04-20 07:32:18 UTC
Created attachment 171300 [details]
Wait I see in writer

A screen capture of my writer document. Vectors and hats are wrong. 
But printing and export pdf are correct.
Comment 10 Luboš Luňák 2021-04-20 09:14:24 UTC
*** Bug 140940 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2021-04-20 12:14:53 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/764360df78535befcc4806736fcbaedbe0e34ea1

fix too wide glyphs with Skia/GDI if horizontal scale is used (tdf#141715)

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 V Stuart Foote 2021-04-20 14:53:15 UTC
*** Bug 140974 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2021-04-20 15:17:19 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/f373aa69b2c3fb2b4679448074a4d2d313c96d34

fix too wide glyphs with Skia/GDI if horizontal scale is used (tdf#141715)

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 V Stuart Foote 2021-04-21 14:26:37 UTC
With this morning TB77 Windows x64 nightly Verified glyphs in sm formulas are being scaled correctly to fit their calculated nodes.

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 42e0ea0a6e4f48967d58fa95081c8ba5a6b08bc6
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 15 Pierre C 2021-04-21 20:33:42 UTC
Maybe this bug can be push to the upcomming LO 7.1.3.2
Comment 16 V Stuart Foote 2021-04-21 23:00:35 UTC
(In reply to Pierre C from comment #15)
> Maybe this bug can be push to the upcomming LO 7.1.3.2

pending as https://gerrit.libreoffice.org/c/core/+/114285

checked a 7.1.4 TB77 build--99ca6b660fd911e9e60b63ae286c588aedfb01d0--all glyphs in sm nodes working, with no other issues noted.
Comment 17 Commit Notification 2021-04-22 09:05:47 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-3":

https://git.libreoffice.org/core/commit/b40e3555d7dc2a18c2fce1387d179bcdfc897d24

fix too wide glyphs with Skia/GDI if horizontal scale is used (tdf#141715)

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Dorange-Pattoret Didier 2021-04-22 16:07:20 UTC
Hello,

Thanks for your work.

I tried, it seems to be ok.
Maybe arrows are not smooth enough ?


Version: 7.1.4.0.0+ (x64) / LibreOffice Community
Build ID: 99ca6b660fd911e9e60b63ae286c588aedfb01d0
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: threaded
Comment 19 Dorange-Pattoret Didier 2021-04-22 16:11:33 UTC
Created attachment 171355 [details]
Arrows smooth enough ?
Comment 20 Adolfo Jayme Barrientos 2021-04-23 22:59:21 UTC
With regard to the smoothness of rendering, please file a separate bug report.