Bug 141729 - document content not displayed / instead showing grey overlay / blank region in writer and calc (macOS 11 aka 10.16 using 2.9 GHz Quad-Core Intel Core i7)
Summary: document content not displayed / instead showing grey overlay / blank region ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: Other macOS (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 141889 141968 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-04-17 18:16 UTC by John Gerrish
Modified: 2021-05-19 10:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows blanked out areas of document display. (884.89 KB, image/png)
2021-04-17 18:16 UTC, John Gerrish
Details
Mac OS vers (50.76 KB, image/jpeg)
2021-04-24 19:04 UTC, John Gerrish
Details
LO Dev vers (69.15 KB, image/jpeg)
2021-04-24 19:05 UTC, John Gerrish
Details
LO calc graphics issue (96.92 KB, image/png)
2021-04-28 10:33 UTC, steve
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Gerrish 2021-04-17 18:16:20 UTC
Created attachment 171260 [details]
Shows blanked out areas of document display.

I upgraded to Big Sur recently on a MacBook Pro (15 inch, 2016) and then upgraded LO to the bleeding edge 7.1.2.2 .  While using writer, simply moving the mouse across the document would cause the areas that the mouse crosses to lose display of the document image.  The document white would be replaced by the background grey.  further movement would blank additional sections.  Additionally, an icon with vertical line and a right pointing triangle (like a start-from-here control) would appear a few inches away, typically down and toward the right.  Dragging mouse across areas where text exists to select highlighting allows the text to reappear and then clicking off the document to lose the highlighting restores that part of the document.
I tried changing some of options in the view menu.  Web view does not exhibit the problem.  Normal view does.  Changing many of the checkmarks for feature options has no effect.
I have attached a screenshot that shows what's happening.
Comment 1 John Gerrish 2021-04-17 18:59:43 UTC
Oh, no!  Version 7.0.5 does the same thing!
Comment 2 John Gerrish 2021-04-17 19:23:04 UTC
Something really weird is going on.  I still had the disk image for LibreOffice_6.4.6_MacOS_x86-64 so I re-installed that.  And it is doing the same thing!  
I think I had successfully used L.O. since the Big Sur upgrade.  I definitely have been using Calc with no problems.  I will restart the OS one more time in case some libraries from newer versions were kept in memory, but I may have to abandon L.O.
Comment 3 John Gerrish 2021-04-17 19:53:02 UTC
Rebooting did not help.  I just checked and I had installed Big Sur on 10 April.  And until yesterday had not used Writer although I had used Calc a lot.  Has anyone else had trouble with Writer on Big Sur?
Comment 4 steve 2021-04-24 08:46:13 UTC
Thanks for the report. Could you install LibreOffice nightly build and see if the problem persists using that build:
https://dev-builds.libreoffice.org/daily/master

Note: To open LibreOffice nightly on macOS please refer to: https://support.apple.com/guide/mac-help/open-a-mac-app-from-an-unidentified-developer-mh40616

If it does please attach a sanitized version of your document to this bug.

Which version of macOS Big Sur are you using? Curious to see if the upcoming 11.3 will change this as there are quite a few changes around graphics in that release.
Comment 5 John Gerrish 2021-04-24 19:04:31 UTC
Created attachment 171389 [details]
Mac OS vers
Comment 6 John Gerrish 2021-04-24 19:05:28 UTC
Created attachment 171390 [details]
LO Dev vers

I installed The nightly LibreOfficeDev build dated April 22 and I do not experience the problem.
Just to be sure, I went back and ran LO 7.0.5 and it still trashes the display.  So, did you do something to fix it?  Thanks.
I am running Mac OS 11.2.3
-Johnnie
Comment 7 steve 2021-04-28 10:25:53 UTC
*** Bug 141889 has been marked as a duplicate of this bug. ***
Comment 8 steve 2021-04-28 10:33:11 UTC
Not a developer. I am seeing the same problem but in calc. Set my bug to duplicate and by that setting this one here to NEW.

Setting component to: LibreOffice as it has happened in both writer and calc.
________________________________________________________________________________
Copy pasting initial report:

Description:
Instead of the table contents the document is cutoff by a grey area.

I am certain there is an existing report (about the same problem in writer iirc) but was unable to find it.

Steps to Reproduce:
This happened on opening a file. No additional action was required to trigger the problem. Sadly this is not always reproducible.

Actual Results:
Bottom area of document is not displayed. Instead it is just a grey area.

Expected Results:
Display documents without grey area.

User Profile Reset: No

Additional Info:
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 41145efffe9d5af358a52b9e114bb01b98b3d7c2
CPU threads: 8; OS: Mac OS X 10.16 aka 11.2.3; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 9 steve 2021-04-28 10:33:37 UTC
Created attachment 171475 [details]
LO calc graphics issue
Comment 10 steve 2021-04-28 10:47:35 UTC
Seting to High Major as per "serious glitch". It is impossible to work with a document if half of it is just a grey box.
Comment 11 Xisco Faulí 2021-04-28 18:31:34 UTC
@Thorsten Wagner, do you reproduce this on your end ?
Comment 12 Thorsten Wagner 2021-04-28 21:00:12 UTC
I am not able to reproduce. As there are the same issues with release 6.4.6 (see comment 2), it seems to be a new issue. Retina fixes were not included in LO 6. These fixes do not seem the root cause therefore.

Only difference between my installation and the release for download is that I am linking against the current macOS SDK. Is there any possibilty to provide a custom tarball for testing? I think the LO tarball is too large for an attachment to this ticket.
Comment 13 Xisco Faulí 2021-04-29 09:00:23 UTC
*** Bug 141968 has been marked as a duplicate of this bug. ***
Comment 14 steve 2021-04-29 09:23:10 UTC
@Tim: which version of macOS are you running?
Comment 15 Tim 2021-04-29 09:50:34 UTC
@14steve
11.3 (Big Sur)

But it's an old problem that led me to uninstall LibreOffice two years ago. About every six months I try it again, and each time Writer doesn't work after a reinstall - it repeats the strange behavior with the grayed out screen areas. 
Doesn't occur in Calc, only in Writer.
Comment 16 steve 2021-04-29 13:36:29 UTC
Thanks for the feedback Tim. Did you remember if previously you also filed a bug about this problematic behavior?

The main problem is, that reproducing the glitch is unreliable: John (who filed this report here) saw the glitch in 7.0.5 and 7.1.2 but not in master. I saw it in master. You and John saw it in writer, I saw it in calc.

So if this problem is not limited to macOS 11 and not limited to LO stable or master and not limited to writer or calc, it appears this would be a very general problem in LO on macOS.

Checking older versions of LO would be very helpful to determine when this problem was introduced or if there is any version of LO that is not affected by this problem.
Comment 17 John Gerrish 2021-04-29 15:24:57 UTC
I have been using LO for many years on MacOS.  It was not until I upgraded to Big Sur that I had the video problem.  After MacOS Upgrade I used Calc multiple times over about 10 days (without trouble) before I had occasion to use Writer and I immediately experienced the failure of rectangular sections of the (Normal view) document below and to the right of the mouse being move that failed to refresh after the mouse cursor crossed the document.  advancing the mouse further upward or to the left would blank additional rectangular area.  Causing areas of the text to be highlighted would restore the normal display.  Changing the View option from Normal to Web would end the problem behavior.  This happened with 3 different release versions of LO I tried it with.  When I installed the LibreOfficeDev version as Steve directed, the problem did not appear.
Comment 18 Tim 2021-04-29 18:08:47 UTC
Thanks for your thoughts, steve.
I just installed version 6.4.7, also here the "writer-bug" occurs. Just like in 7.1.3.1 (RC1).
As John described, it is only visible in "Normal view", it disappears in the web layout.
As I said, this was the main reason for me to delete LO from my Mac altogether - except for periodic attempts to revive it.
I didn't find anything in Google searches about it for a long time, so I decided to join here at the Bug Report...
Comment 19 John Gerrish 2021-04-29 18:24:58 UTC
I guess I should have mentioned that I skipped Catalina version completely and so I had not upgraded beyond, Yosemite.  So Tim saying that the problem existed for him for 2 years (If he was staying up to date on MacOS) is not inconsistent with my experience.  Maybe it has been a problem for previous version as well and I just missed since I stay away from the bleeding edge.
Btw, this morning while using Calc, while changing column width by dragging column header border, it is blanking everything downward to bottom of the window below where the mouse is dragging (but not the column header row itself). Sometimes when you first begin the resize the blanked area has some weird magnified graphic artifacts.  When you release the trackpad dragging, the display returns to the normal gridlines and cell contents.  I had not noted that before today.
Comment 20 Tim 2021-05-01 09:31:16 UTC
@John that is very possible! I have my Mac running on the latest version of Mac Os...
since I found nothing on google search about this bug, I assume that it is rather rare. 
Maybe there will be a solution in the future! Unfortunately I can't program well enough to deal with the problem myself. Thanks a lot to all of you!
Best regards, Tim
Comment 21 Tor Lillqvist 2021-05-17 13:39:46 UTC
So there is no reproducer document here, just screenshots?
Comment 22 Tor Lillqvist 2021-05-17 14:15:45 UTC
(Can not reproduce, but I guess that is not surprising.)
Comment 23 Tim 2021-05-17 14:42:05 UTC
In Comment 8 is my attempt to document the reproduction of the error. What information is still missing?
Comment 24 Tor Lillqvist 2021-05-17 15:21:53 UTC
@TIm, so it happens for every document? Even just typing into some empty new document, and soon it will show up?
Comment 25 John Gerrish 2021-05-17 15:28:21 UTC
Please note that in comment 6 I said "I installed The nightly LibreOfficeDev build dated April 22 and I do not experience the problem."  I have been using that build without problem.
Today I downloaded the current "early adopter" version which installed as 7.1.3.2 and it exhibits the problem when starting a new text document.
I am now downloading this morning's daily master (it takes a while) and I will report on whether it exhibits the problem or not.
Comment 26 John Gerrish 2021-05-17 15:58:31 UTC
And last night's (Shows as 2021-May-17 03:24 for my TZ) master LibreOfficeDev build Writer functions as it should in normal view mode with no problem for a brand new Writer Document
However, I opened calc and without inputting anything, click-drag on a column header divider to adjust the column width and during the dragging process, I get some wild black and white graphic artifacts, but upon releasing the click-drag, the disturbed display refreshes to the proper grid lines.  Click-drag for adjusting row height does the same sort of thing.
This is using the version of Big Sur identified in the Mac OS version attachment to this bug.
Comment 27 John Gerrish 2021-05-17 16:44:50 UTC
Yes,  I started a new document, and it came up paper-white in "normal" view.  I moved the mouse onto the document, and everything below and right of the mouse turns to background-grey.  Mouse to the top and the top margin stays white, but everything below top margin is grey.  I started to type, and the rectangle of the line to the right of what I was typing, became paper-white.  hit return and cursor moved to next line and refreshes the document below to paper-white.  move the mouse in the document and everything inside the margins below the mouse goes background-grey.
If you click a different window (like to type this comment) that doesn't completely cover the writer document, you can see the writer document refresh to paper-white in the behind the front window.
It is kind of like someone was trying to speed up the display by cutting out some of the repeated refreshing of the window as the mouse cursor occludes the window content.  Other actions put the display back to rights.
In writer, this makes it nearly unusable.  The problem in calc (my last comment) does not impact usability (much) but doesn't look right.
Both calc and writer seem to display un-initialized video memory with oversized graphic artifacts, but this tends to subside after repeatedly testing eventually overwrites (so it seems).  The most common one is a vertical line with a right pointing triangular point.  It tracks the mouse movement but with some inverse to the vertical movement and generally about half the window width to the right but will blink out at anytime.  Really weird.
Would you like to do a zoom meeting with me and I could share my screen?  I don't quite know how the video weirdness would show.
Comment 28 Tim 2021-05-17 17:06:54 UTC Comment hidden (obsolete)
Comment 29 Tim 2021-05-17 17:07:12 UTC Comment hidden (obsolete)
Comment 30 John Gerrish 2021-05-17 17:15:24 UTC
Tim, have you tried the Nightly build?  It has been working okay for me.  Makes you wonder what piece of it is not getting incorporated into the production releases.
Comment 31 Tim 2021-05-17 17:51:41 UTC
@John Wow, it works! Installed 2021-05-16_08.22.45 and the scrolling error is gone. Thanks a lot!
Now let's hope that this feature will not be lost in the final version...
Comment 32 John Gerrish 2021-05-17 18:06:10 UTC
But, adjusting column widths in calc, has some weirdness still, yes?
Comment 33 Aron Budea 2021-05-17 19:25:47 UTC
(In reply to John Gerrish from comment #32)
> But, adjusting column widths in calc, has some weirdness still, yes?
Yes, that is tracked under bug 142061, please follow that bug report for updates.
Comment 34 Aron Budea 2021-05-18 00:06:12 UTC
(In reply to Tim from comment #31)
> @John Wow, it works! Installed 2021-05-16_08.22.45 and the scrolling error
> is gone. Thanks a lot!
> Now let's hope that this feature will not be lost in the final version...

(In reply to John Gerrish from comment #30)
> Tim, have you tried the Nightly build?  It has been working okay for me. 
> Makes you wonder what piece of it is not getting incorporated into the
> production releases.
Could you check with a 7.1 daily build (assuming the one you tried is of the master branch, not 7.1), to confirm the bug is still there?
https://dev-builds.libreoffice.org/daily/libreoffice-7-1/

7.1.3.2 was tagged three weeks ago, and it's possible the fix got backported since.
Comment 35 John Gerrish 2021-05-18 16:52:36 UTC
@aron
I installed "LibreOfficeDev_7.1.4.0.0_MacOS_x86-64.dmg" which was dated last night (2021-May-18 05:58 in my TZ).  
It shows Version: 7.1.4.0.0+ / LibreOffice Community
Build ID: ac0eb504a38321849b854889598a28d0687196ea
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Now Writer does NOT exhibit the problem.

Calc, behaves the same.  The early attempts at changing row or column size clears the area dragging across, sometimes with some b/w graphic artifacts in the affected area, but usually after a couple of attempts, clean white.  upon releasing the click-drag, display returns to normal grid lines.  This does not affect usability but is a little distracting.
Comment 36 Aron Budea 2021-05-19 00:12:45 UTC
(In reply to John Gerrish from comment #35)
> I installed "LibreOfficeDev_7.1.4.0.0_MacOS_x86-64.dmg" which was dated last
> night (2021-May-18 05:58 in my TZ).  
...
> Now Writer does NOT exhibit the problem.
Great, let's assume this bug is fixed. To be on the safe side, the first RC of 7.1.4 will be built, and should be available early next week, it might be worth double-checking with that.

They'll be at the prerelease section of the download page:
https://www.libreoffice.org/download/download/
Or here:
https://dev-builds.libreoffice.org/pre-releases/

> Calc, behaves the same.  The early attempts at changing row or column size
As I wrote, please follow bug 142061 on this.

Based on the feedback, closing this bug report as WORKSFORME, if anyone else still sees visual issues that isn't bug 142061 or another already reported bug, please create a fresh report.
Comment 37 Xisco Faulí 2021-05-19 10:14:40 UTC
(In reply to John Gerrish from comment #35)
> @aron
> I installed "LibreOfficeDev_7.1.4.0.0_MacOS_x86-64.dmg" which was dated last
> night (2021-May-18 05:58 in my TZ).  
> It shows Version: 7.1.4.0.0+ / LibreOffice Community
> Build ID: ac0eb504a38321849b854889598a28d0687196ea
> CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> Now Writer does NOT exhibit the problem.
> 
> Calc, behaves the same.  The early attempts at changing row or column size
> clears the area dragging across, sometimes with some b/w graphic artifacts
> in the affected area, but usually after a couple of attempts, clean white. 
> upon releasing the click-drag, display returns to normal grid lines.  This
> does not affect usability but is a little distracting.

Hi John,
What about Libreoffice 7.2 alpha1 < https://dev-builds.libreoffice.org/pre-releases/mac/x86_64/LibreOfficeDev_7.2.0.0.alpha1_MacOS_x86-64.dmg > ?