Bug 141803 - FILEOPEN ODT gutter is not subtracted from margin in "mirrored" page layout
Summary: FILEOPEN ODT gutter is not subtracted from margin in "mirrored" page layout
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Gutter-Margins
  Show dependency treegraph
 
Reported: 2021-04-21 14:26 UTC by Regina Henschel
Modified: 2022-04-14 18:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file with gutter on mirrored page layout (17.45 KB, application/vnd.oasis.opendocument.text)
2021-04-21 14:26 UTC, Regina Henschel
Details
compare of first load with save and reload (92.31 KB, image/png)
2021-05-03 14:38 UTC, Regina Henschel
Details
first open looks sane (130.20 KB, image/png)
2021-05-03 15:30 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2021-04-21 14:26:35 UTC
Created attachment 171336 [details]
file with gutter on mirrored page layout

Open attached document.
Save and reload.
Error: The margin is wrong.

Idea was, that the value from gutter is added to the margin on save and subtracted on load to keep the documents compatible.

Subtracting is missing in case of "mirrored" page layout.

I see the error in Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 42e0ea0a6e4f48967d58fa95081c8ba5a6b08bc6
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 1 Miklos Vajna 2021-05-03 13:36:35 UTC
Could you please provide a bit more info? Here is what I tried:

1) A made a copy of your bug document (orig.odt -> test.odt)

2) I opened your bug document (test.odt)

3) I saved it, closed test.odt

4) Compared orig.odt and test.odt on master: looks the same

5) Compared orig.odt and test.odt on 7.1.1.2: looks the same

So what is the actual problem to be fixed here?

Thanks.
Comment 2 Regina Henschel 2021-05-03 14:38:00 UTC
Created attachment 171610 [details]
compare of first load with save and reload

The screenshot shows the appearance directly after load and the appearance after save and reload. Notice the difference in the width of the text area.

Tested with Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: f81871ccbbe118b4ac93325a29f7c6b26765cb6e
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 3 Miklos Vajna 2021-05-03 15:30:50 UTC
Created attachment 171615 [details]
first open looks sane

Thanks, for some reason I get the second layout even on first open. I attach how it looks like here.

Let's wait till a 3rd person tries to reproduce this and then we can learn if I'm holding it wrong or not. :-)
Comment 4 Buovjaga 2022-04-14 13:52:50 UTC
No problem for me

Arch Linux 64-bit
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 9a42c99d7b3e8a8429f14d7d851f3d186fa04594
CPU threads: 8; OS: Linux 5.17; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded Jumbo
Built on 14 April 2022
Comment 5 Regina Henschel 2022-04-14 18:21:45 UTC
I can no longer reproduce it with today master.