Bug 141807 - Right and Top Page Margins always synced when using gtk3 VCL
Summary: Right and Top Page Margins always synced when using gtk3 VCL
Status: RESOLVED DUPLICATE of bug 138471
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3 Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2021-04-21 16:18 UTC by Ronny Standtke
Modified: 2021-04-25 19:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot showing the issue with the gtk3 VCL (27.17 KB, image/png)
2021-04-21 16:18 UTC, Ronny Standtke
Details
screenshot showing that the issue is not there when using the kf5 VCL (31.26 KB, image/png)
2021-04-21 16:19 UTC, Ronny Standtke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Standtke 2021-04-21 16:18:08 UTC
Created attachment 171340 [details]
screenshot showing the issue with the gtk3 VCL

When using LibreOffice with the gtk3 VCL the right and top page margins are always synced so that they cannot be set independently.
I double checked with the gen and kf5 VCLs and the bug is not there.
Comment 1 Ronny Standtke 2021-04-21 16:19:23 UTC
Created attachment 171341 [details]
screenshot showing that the issue is not there when using the kf5 VCL
Comment 2 Ronny Standtke 2021-04-25 14:00:24 UTC
This is a strange bug. I can reproduce it reliably on Debian with the version in Debian backports (1:7.0.4~rc2-1~bpo10+2) but not on Ubuntu (version 1:7.0.5-0ubuntu0.20.10.1).

Maybe it is a Debian packaging bug? I would be glad if someone more familiar with LibreOffice than me would take a closer look at this.
Comment 3 Caolán McNamara 2021-04-25 19:08:26 UTC
I think this is a duplicate of bug 138471 which was indeed present in 7.0.4 but fixed in 7.0.5

*** This bug has been marked as a duplicate of bug 138471 ***