Bug 141838 - Fontwork dialog scroll 'showing' full new page, except it only contain 1 entry. you shouldn't be able to scroll that far
Summary: Fontwork dialog scroll 'showing' full new page, except it only contain 1 entr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 143558 (view as bug list)
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2021-04-22 18:44 UTC by Telesto
Modified: 2022-07-08 12:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-04-22 18:44:21 UTC
Description:
Fontwork dialog scroll 'showing' full new page, except it only contain 1 entry. you shouldn't be able to scroll that far

Steps to Reproduce:
1. Open Impress
2. Insert -> Fontwork
3. Scroll down (empty area with only 1 'fontwork template'

Actual Results:
big white space

Expected Results:
Showing previous + the one 'new'


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 41145efffe9d5af358a52b9e114bb01b98b3d7c2
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: threaded
Comment 1 Telesto 2021-04-22 18:45:43 UTC
Still OK with (different dialog size)
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 2 Raji 2021-04-23 13:15:16 UTC Comment hidden (obsolete)
Comment 3 Telesto 2021-04-23 17:06:02 UTC Comment hidden (obsolete)
Comment 4 Aron Budea 2021-07-31 22:01:11 UTC
Actually, the regression is from the following commit. Fine with gtk3 VCL plugin in Linux, but occurs with gen, and in Windows. Adding CC: to Szymon Kłos.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=25f33c3393895edced99cb69c7a450b9e2bb5343
author		Szymon Kłos <szymon.klos@collabora.com>	2021-01-08 09:28:38 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2021-01-14 10:20:27 +0100

Fontwork dialog: use iconview
Comment 5 Justin L 2022-01-24 08:21:10 UTC
Seems unimportant. As Aron notes, this can also be seen in Linux with
SAL_USE_VCLPLUGIN=gen instdir/program/soffice
Comment 6 Aron Budea 2022-05-20 18:34:13 UTC
*** Bug 143558 has been marked as a duplicate of this bug. ***