Bug 141958 - character and list Style selector in toolbars don't display good style category
Summary: character and list Style selector in toolbars don't display good style category
Status: RESOLVED DUPLICATE of bug 88512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.1.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-29 06:38 UTC by bentusiii@yahoo.fr
Modified: 2022-04-20 19:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bentusiii@yahoo.fr 2021-04-29 06:38:32 UTC
Description:
The selectors for "character style" ans "list style" in the "style format" toolbar (which need to be activated in "personnalise..." settings) are not referring to the corresponding styles catgories but to "paragraph styles" each time. thus there are three time the same selector's target in the toolbar despite different names.

Steps to Reproduce:
* warning : all "denominations" are estmated from french locale from memory (can't go back to english locale).
1. go to "menu / display / toolbar/ personnalise".

2. select "toolbar" tab, then select the target "style format" toolbar as a destination for settings (right side). Activate all the unactivated "charcter style" and "list style" selectors (the ones with paint bucket as an icon --with breeze icons) -- OR search fort "style" in the left side "all icons available" list and apply them in any toolbar. Validate and go back to main window.

3. try to select different "character style" (need to have created  someones at first) from the corresponding selector. Do the same for other "list style" selector. 

Actual Results:
it should display only paragraph styles in each of the thee selectors, which is not the purpose.

Expected Results:
display "character styles list" to be chossen from in the "charater style selector" ans display "list styles list" to be chossen from in the "list style selector".


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
thus this bug could help advanced users (i know not a lot of users manage character styles) to avoid the Bug 141952 problem of having ti display style panel permanently to select character styles from (as they could select them from the toolbar selector).
Comment 1 Dieter 2021-05-14 06:18:22 UTC
Sorry, but I couldn't find "Character Style" or "List Style"

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 1675a68526c43c6c6e4dc850ee911f0c1de75c88
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Would indeed be helpful, if you could describe the problem with English UI. You can change Language in Tools => Options => Language Settings => Languages
Comment 2 Buovjaga 2022-04-20 11:47:33 UTC
Indeed, there are no commands for Character Style or List Style available in toolbar customisation.

bentusiii: please give more information.
Comment 3 sdc.blanco 2022-04-20 12:23:39 UTC
(In reply to bentusiii@yahoo.fr from comment #0)> 
> 3. try to select different "character style"
This is bug 88512

It is true that the List Styles dropdown box does not work either. This is bug 107000.

Meanwhile, afaict, these commands do not appear in the Customize dialog in LO 7.2 and onward -- I failed to find a relevant bz ticket for their removal -- and did not look in the git history. 

@bentusiii -- you are right, these commands do not work.  And when you upgrade, .then they will not be available in toolbar/ personnalise".
Comment 4 Buovjaga 2022-04-20 12:31:43 UTC
Thanks, I guess let's set to NEW even though difficult to test. I guess one would have to use a macro and assign it?
Comment 5 sdc.blanco 2022-04-20 13:02:18 UTC
(In reply to Buovjaga from comment #4)
> Thanks, I guess let's set to NEW even though difficult to test
Ummm...I would set it DUP of bug 88512 (for Character) or bug 107000 (for List)

If you want to test with a macro, I believe the appropriate .uno for Character Styles is:

.uno:StyleApply?Style:string=User Entry&FamilyName:string=CharacterStyles
Comment 6 Buovjaga 2022-04-20 13:03:40 UTC

*** This bug has been marked as a duplicate of bug 88512 ***
Comment 7 sdc.blanco 2022-04-20 13:27:38 UTC
@bentussi -- as a workaround...

Method 1 (for only a few character styles):  Add them to your Formatting (Styles) toolbar, use the "Styles" category to find specific styles.

Method 2:  Make a new toolbar, populating it with the character styles you want. 

(same story for list styles, though many of the standard list styles already have toolbar icons or in menus).
Comment 8 bentusiii@yahoo.fr 2022-04-20 18:29:03 UTC
hi thanks for having a look to this bug, it's been a while... i just checked in V7.3.2.2, that's right they have disappeared. That is a strange way to solve bugs : no function, no problem !!!  This is a pity because the ideau could be very useful. I often use character styles in parallel of paragraph styles and the only easy way to access is in side panel. Thus, because navigator have been put in separated window or side panel, i hava to toggle every time... very time consuming.

i have specified this (very personnal way of configuring LO.W, i admit it) in several bugs that may have been removed since. but you could have a look there : #148460

Thanks for considering a global improvement in managing styles, navigator and side panel all together.
Comment 9 sdc.blanco 2022-04-20 19:14:28 UTC
(In reply to bentusiii@yahoo.fr from comment #8)
> in V7.3.2.2, that's right they have disappeared. That is a strange way to
> solve bugs : no function, no problem !!!  
It was probably removed to avoid getting reports like this one, but....the enhancement request is not solved or removed. The dropdown box for character styles is still an open bug 88512 (and you have been added to its CC list). And the dropdown box for list styles is bug 107000.