Bug 142073 - Calc: When I save XLSM excel workbook, I lost all connection between objects and VBA macros.
Summary: Calc: When I save XLSM excel workbook, I lost all connection between objects ...
Status: RESOLVED DUPLICATE of bug 105813
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2021-05-04 07:02 UTC by Laurent Louvet
Modified: 2022-09-25 02:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Module1 - Se situer.xlsm (contain macros but impossible to link with buttons) (2.51 MB, application/zip)
2021-05-04 07:02 UTC, Laurent Louvet
Details
disable-vba-refactoring.oxt: prevent changing Excel macro when saving. (4.32 KB, application/vnd.openofficeorg.extension)
2022-09-06 20:48 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Louvet 2021-05-04 07:02:01 UTC
Created attachment 171624 [details]
Module1 - Se situer.xlsm (contain macros but impossible to link with buttons)

Calc: When I save XLSM excel workbook, I lost all connection between objects and VBA macros.

XLSM document provide from Excel 2010. Recorded onto XLSM because document contain VBA macros.

When i read this document with Libre office : no problem.
The problem exists when I save this file from Libre Office program.
If I want to re-open this file, then, all macros linked from objets (like button, or, event in a sheet) are lost.

(See "Module 1 - Se situer" tab). There is some buttons that are unliked.
Comment 1 Laurent Louvet 2021-05-05 16:04:08 UTC
Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: CL
Comment 2 Justin L 2022-09-06 20:48:20 UTC
Created attachment 182272 [details]
disable-vba-refactoring.oxt: prevent changing Excel macro when saving.

Perhaps this extension will help. It prevents LO from making changes to the macro code. So you have to make it all work using Excel, but after that you can USE the document in LibreOffice, and saving it will not break the macros.
Comment 3 Justin L 2022-09-06 20:51:38 UTC
AFAICS, the supplied .xlsm document is already broken. A working document (either an Excel document or an ODS) would be necessary for further enhancement.
Comment 4 Justin L 2022-09-23 23:00:53 UTC Comment hidden (obsolete)
Comment 5 Justin L 2022-09-25 02:14:35 UTC

*** This bug has been marked as a duplicate of bug 105813 ***