Bug 142197 - Mac OS X Calc column resizing causes false display
Summary: Mac OS X Calc column resizing causes false display
Status: RESOLVED DUPLICATE of bug 142061
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-10 15:02 UTC by tymcik
Modified: 2021-05-10 17:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tymcik 2021-05-10 15:02:51 UTC
Description:
When I pull the boundary of a column, the content of neighbor columns is shown in the gap, enlarged like through a lense.
After release everything is fine, but it disturbes intentional shifting. See Screenshot.

Steps to Reproduce:
1. Take any Calc file with values
2. Adjust column width
3. If a neighbor column has values, you can see them repeated in the adjacencies like through a lense

Actual Results:
Weird depictions, depending on distance you pull.
Actually only the first time - if you want to repeat it, the "pulling shadow" becomes white only.

Expected Results:
Wysiswyg live update on screen while pulling


Reproducible: Always


User Profile Reset: No



Additional Info:
two screenshots
https://tymcat.owncube.cloud/index.php/s/kq6LNM2dnpKpaJr

This version of LibreOffice was installed only a few days ago and it happened in the first file edited.
Comment 1 tymcik 2021-05-10 15:06:15 UTC
It's on a Macbook Pro 15" Retina, late 2012, OS X 10.14.6 Mojave
Comment 2 Alex Thurgood 2021-05-10 15:25:17 UTC
@tymcat : does it only do this with Dark Theme icons, or does it do this irrespective of the chosen icon/desktop theme ?
Comment 3 m.a.riosv 2021-05-10 15:32:45 UTC
Maybe a dup https://bugs.documentfoundation.org/show_bug.cgi?id=142061
Comment 4 Alex Thurgood 2021-05-10 15:37:15 UTC
For example, when I try this on

Version: 7.1.2.3 / LibreOffice Community (Collabora AppStore download)
Build ID: a393d9064b7eb849da7f488ab43f56a404be32ae
CPU threads: 8; OS: Mac OS X 11.3; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded


I get white blanking out of the columns over which I'm dragging the column boundary.

In other words the redraw is incorrect.
Comment 5 Alex Thurgood 2021-05-10 15:38:59 UTC

*** This bug has been marked as a duplicate of bug 142061 ***
Comment 6 tymcik 2021-05-10 17:45:08 UTC
(In reply to Alex Thurgood from comment #2)
> @tymcat : does it only do this with Dark Theme icons, or does it do this
> irrespective of the chosen icon/desktop theme ?

it occurs independently of icon choice.